Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors 6502
Original poster
Sep 15, 2015
I have Early 2015 macBook Air-macOS 12.6.3 and Safari Version 16.3 (17614., 17614). I rediscovered Pluto TV free streaming service. It would not play in Safari, however discovered that it would play on Brave browser but I don't like having different browsers on machine. Was searching around the web for a solution for Safari but didn't find anything currently relevant on Pluto site or otherwise. I discovered the solution myself playing around. While on the Pluto TV site, click Safari on the toolbar up top left. You will see Settings for in the submenu. Click that. Another submenu will come up. On the Auto-Play item I suggest select Allow All Auto-Play. On Pop-up Windows I selected Allow. It now plays shows flawlessly! I'm guessing this could be an issue on other versions of macOS/Safari as well. Hope this helps someone.
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.