2016 15" MBP + AirPods = constant skipping and glitching?

Discussion in 'MacBook Pro' started by fs454, Dec 21, 2016.

  1. fs454, Dec 21, 2016
    Last edited: Dec 21, 2016

    fs454 macrumors 68000

    Joined:
    Dec 7, 2007
    Location:
    Los Angeles / Boston
    #1
    Hey all,

    So I finally snagged some AirPods today and while they work great on my iPhone, they give me constant half-second dropouts every 10-15 seconds when I use them with my new Touch Bar MBP, be it YouTube, Netflix, or just Spotify.

    I can't pinpoint what's going on exactly, but it maybe has something to do with when the laptop is sending/receiving wifi data? It's connected to a 5ghz network, and I have no other BT devices nearby except for the iPhone. Something seems to be causing interference, but at the same desk, with nothing moved around, switching them over to the iPhone 7 Plus results in perfect audio. Tried a reboot, reconnect, nothing.


    Anyone else have this issue? I feel like there isn't a fix yet since the product is days old, but I find this very strange.

    :edit: Recorded the issue with Voice Memo:
    https://soundcloud.com/jesse-dacri/airpods-issue-when-connected-to-2016-15-macbook-pro

    I get this constantly with any audio source coming from my MBP.
     
  2. fs454 thread starter macrumors 68000

    Joined:
    Dec 7, 2007
    Location:
    Los Angeles / Boston
    #2
    Update: I turned off Wifi and continued playing music - the glitching stopped. Wifi back on, glitching still gone. Restarted the MBP, put the AirPods in the case, pulled em out, glitching is back.

    Strange. To the Apple Store I go.
     
  3. MH01 Suspended

    MH01

    Joined:
    Feb 11, 2008
    #3
    Sounds like a software bug, I've had a good play with the AirPods and they really work best with iPhones or iPads, that said my iPad Pro using iOS 9 can't even see the AirPods . I'd expect quite a few bugs to be ironed out in the next few updates . My AirPods paired with my iPod nano...awful :(
     
  4. Bbqthis macrumors 6502a

    Bbqthis

    Joined:
    Apr 12, 2015
    Location:
    Bay Area, CA
    #4
    Any updates? I had the exact same issue with my 2014 5K iMac
     
  5. jk73 macrumors 6502

    Joined:
    Jul 19, 2012
    #5
    Just as a general reminder, people with AirPods issues should make sure to also send feedback to Apple at:

    apple.com/feedback

    There's no AirPods page/section as of a few moments ago, but I assume feedback sent via the MBP, iPhone, or Watch pages would get routed accordingly.
     
  6. fs454 thread starter macrumors 68000

    Joined:
    Dec 7, 2007
    Location:
    Los Angeles / Boston
    #6
    It mysteriously stopped. It's come back once, but my attempt of toggling wifi off and on again while the AirPods are connected fixed it twice in row. I submitted feedback for this.
     

Share This Page