2016 MBP Graphic Glitches Persist with 10.12.2

Discussion in 'MacBook Pro' started by va1984, Jan 12, 2017.

  1. va1984 macrumors member

    Joined:
    Jan 27, 2011
    #1
    I would like to know if anybody else is still having graphic glitches with the new 2016 MBP.
    I bought the 13" noTouchBar edition (an impulse buy when Amazon cocked up and offered it for $1140).
    At first I t had frequent graphics glitches. I waited for the first macOS update (10.12.2 build 16C67) that was suppose to fix them. It didn't.
    Since I was already a little disappointed to have received a laptop with a battery manufactured 1.5 years ago (according to the metadata pulled by the Battery Health app), and the graphic glitches persisted, albeit more rarely, I thought what the hell, and requested a replacement from Amazon.
    Now the replacement arrived, brand new, battery manufactured one month ago, updated to the latest macOS build and... well, look at the video.



    I find it hard to believe that I am the only one getting two (2) faulty laptops in a row. I must have owned over 50 apple computers and devices and frankly I don't ever recall getting a faulty piece of hardware (ok, Time Capsules aside).

    So this is a software problem. Maybe linked to PDF rendering (I work with PDFs a lot). And I am not the only one, right?

    [note to pedants: I know that the battery's age and the graphics issues are unrelated. I am just mentioning that to explain why, even though I was already reasonably certain that this was a software issue, I went ahead and requested a replacement]
     
  2. Sanpete macrumors 68020

    Joined:
    Nov 17, 2016
    Location:
    Utah
    #2
    That is bizarre. Either extremely bad luck or you've discovered another bug.
     
  3. jimgl macrumors newbie

    Joined:
    Dec 16, 2016
    #3
    I experienced a similar pixelated display effect on the login screen after waking from overnight sleep. I installed Sierra 10.12.3 Beta 3 and no longer have the display glitch. It appears that the next Sierra release will fix this problem. Click on this thread for more information.

    Jim
     
  4. d14b0ll0s macrumors member

    Joined:
    Dec 26, 2011
    #4
    I just got tiny purple glitches (dots or a line) on my tMBP 13" (it was the first time I had the uptime of 4 days, I think, but I'm not sure whether this is related. A reboot helped.
     
  5. Jaekae macrumors 6502

    Joined:
    Dec 4, 2012
    #5
    Try reinstall 10.12.2 again, the latest have a different buildnumber
     
  6. d14b0ll0s macrumors member

    Joined:
    Dec 26, 2011
    #6
    I've experienced the issue for the second time on 10.12.2 now, with only a day's uptime, and got the funky glitches again, this time already on the login screen. I went to Accessibility settings, thinking one of the display settings there might revert the issue, and in fact clicking 'Invert colors' (and then back to normal) has helped!
     
  7. vatter69 macrumors 6502a

    vatter69

    Joined:
    Feb 4, 2013
    #7
    Same issue on 13 ntb - seems to only happen when driving 1280x800 according to the other thread. After i log in, the issue is gone, though.

    Waiting to see at 10.12.3 fixes it.
     

Share This Page