2016 rMB - No video on HDMI?

Discussion in 'MacBook' started by mikes63737, Apr 28, 2016.

  1. mikes63737 macrumors 65816

    Joined:
    Jul 26, 2005
    #1
    Picked up an m3 rMB this past weekend... and I'm not able to get any video out over HDMI.

    I've tried using two different highly-rated 3rd party USB-C "hubs" (reviews say works great w/ '15 model) from Amazon (USB-C to USB-A and HDMI). With both of these, my rMB detects the external display (shows in Display preferences) and the display shows up in System Report.

    I've tried 3x HDMI cables and 3x displays, adjusting to 1080p, 1080i, 720p, etc. I have an rMBP which works on each of these configurations. I also tried resetting SMC.

    Charging + USB ports on these hubs work, just not HDMI.

    Am I missing something simple, or is there possibly an issue with my rMB? Is there a difference between how the '15 and '16 models do video-out? The nearest Apple is stupid busy on the weekends and I'd love to avoid making a trip :)

    Thanks
     
  2. Brookzy macrumors 68040

    Brookzy

    Joined:
    May 30, 2010
    Location:
    UK
    #2
    Is there any way you can get your hands on the official Apple adapter to try if that works?
     
  3. Picapau21 macrumors 6502

    Joined:
    Apr 26, 2015
    #3
    If the apple adapter does work then it just confirms my worries with 3rd party adapters. With iPhones i have wasted a lot of money on 3rd party stuff that either just doesn't work or stops working after a short period. They do use proprietary connection though (old 30-pin, lightning). You wouldn't expect that with USB-C cables as there are technically meant to be universal.
     
  4. mikes63737 thread starter macrumors 65816

    Joined:
    Jul 26, 2005
    #4
    Yeah, I guess that's the next step. Man, I hate the Apple adapters that have a short cord that won't bend.

    Thanks!
     
  5. joudbren macrumors regular

    Joined:
    Apr 13, 2007
    Location:
    Edmonton, Alberta, Canada
    #5
    I have a new 16' rMB i5 and Apple multi-port adapter. Everything is working like a charm including HDMI video. Tested Netflix and definitely working on external display. I did do the flash upgrade on the multi-port adapter from Apple which I believe may have sorted out some HDCP issues as well that others were complaining about. Not sure where I read that though.

    Anyways, definitely working for Netflix on new AOC 27" Q2778VQE monitor running at 2560x1440 resolution over HDMI on Apple multi-port adapter. USB keys and charging pass-through also working at same time. Cheers!
     
  6. boltjames macrumors 68030

    boltjames

    Joined:
    May 2, 2010
    #6
    You need the official Apple USB-C to HDMI Adapter.

    A bunch of us went through this a year ago, tried our legacy HDMI to USB adapters and such, there's something about the USB-C protocol that's different for HDMI, you need the Apple adapter (or find a third party one that supports HDMI and confirms it works with the RMB).

    BJ
     
  7. mikes63737 thread starter macrumors 65816

    Joined:
    Jul 26, 2005
    #7
    Thanks everyone, much appreciated. I did pick up an Apple USB-C adapter. I really hate how short / rigid it is, but it's working perfectly.

    Just as a data point in case it helps avoid anyone else some stress: these are the two adapters that did NOT work with my 2016 model despite them claiming compatibility.

    Aukey: http://www.amazon.com/dp/B01B7M5SMY
    Vtin: http://www.amazon.com/dp/B01AAK5FRC
     

Share This Page