2017 15 inch MacBook Pro - video playback stuttering

Discussion in 'MacBook Pro' started by ndpitch, Jul 14, 2017.

  1. ndpitch macrumors 6502

    Joined:
    Jun 9, 2010
    #1
    I've noticed that video playback on my new MacBook on sites such as YouTube, or other streaming videos, skips frames every now and then. Maybe every 45 to 60 seconds or so. Audio continues smoothly but the video stutters and it's quite annoying. It doesn't happen on the MacBook Air that this new machine replaced - so it's not a network issue.

    Anyone experiencing something similar?

    All software is up to date. I'm running Safari. I should try Chrome to see if it happens there, too. I wasn't sure if this might be a driver issue, software, hardware, etc

    System specs are below for reference.

    15 inch 2017 MacBook Pro
    3.1 GHz i7
    16 GB RAM
    Radeon 560 4 GB
    1 TB flash storage
     
  2. PieTunes macrumors 6502

    PieTunes

    Joined:
    May 6, 2016
    Location:
    San Diego, CA
    #2
    My base model 2017 non touchbar 13" is far less capable than yours and I've never had this happen. Do you have any extensions installed in Safari? If so I would try disabling them all, test things out again, and if the issue isn't apparent, re enable the extensions one by one until you find the culprit.
     
  3. PBG4 Dude macrumors 68020

    PBG4 Dude

    Joined:
    Jul 6, 2007
    #3
    Zero issues with video playback on my 2017 15" MBP. Watched a ton of YouTube videos and streamed a bunch of Rick & Morty to my Apple TV; all problem free.
     

Share This Page