2017 iMac prefers wifi over ethernet connection

jmpage2

macrumors 68040
Original poster
Sep 14, 2007
3,072
386
I'm banging my head against a rock trying to figure this one out.

I have a 2017 i7 iMac and it has a wired ethernet connection to a gigabit switch.

On the same network I have a WiFi enterprise mesh, both networks share a common DHCP server.

At some point in the past few months I enabled WiFi on the iMac, I think it might have been related to getting some features to work with AirPlay or my iWatch or something.... whatever.

I've noticed since that file transfers to my NAS have been slow. Interestingly enough, if I disable WiFi on the iMac temporarily then transfer speeds go through the roof and I get the performance I am used to.

A google search turned up articles in which people claimed that the Mac obeys the "Set Service Order" preference in system preferences -> Network area. I have that set with Ethernet as the top choice but my iMac continues to prefer the WiFi connection.

Does anyone have any other troubleshooting ideas on this one?

Thanks
 

Darmok N Jalad

macrumors 68030
Sep 26, 2017
2,803
11,847
Tanagra (not really)
Using unlock from AW requires wifi and bluetooth to be enabled. I'm betting that because you have that feature (and Airplay) enabled, your iMac stays on wifi in order for those features to work correctly.
 

jmpage2

macrumors 68040
Original poster
Sep 14, 2007
3,072
386
Using unlock from AW requires wifi and bluetooth to be enabled. I'm betting that because you have that feature (and Airplay) enabled, your iMac stays on wifi in order for those features to work correctly.
The issue isn't that the iMac stays on WiFi.

The issue is that the iMac is preferring the WiFi connection over the much faster Ethernet connection for things like transferring files over the network.
 

jmpage2

macrumors 68040
Original poster
Sep 14, 2007
3,072
386
Ah, ok. This old thread suggests that you can try connecting to your 5GHz wifi network. Seems like a bit of a long shot, but maybe worth a try?
Thanks for taking the time to respond.

I have an enterprise grade network that presents the 2.4ghz and 5.0ghz network to the clients on the same SSID and the iMac is always connected to the 5.0ghz band.

There's no way I'm going to redesign a $1,000+ wireless network and split the 2.4ghz and 5.0ghz bands just because the iMac isn't working right.
 
  • Like
Reactions: Ifti

DeltaMac

macrumors G4
Jul 30, 2003
10,468
2,788
Delaware
Go to Networks, then Wifi, and click the Advanced button.
Make sure the Wifi network that you expect is at the top of the list in Preferred Networks list.
You can delete any other items than the Wifi that you expect to use.
OR - you can delete all items, so the preferred items list is empty.

Maybe that will help make your connection what you might be expecting.
 

imacken

macrumors 65816
Feb 28, 2010
1,232
124
I'm banging my head against a rock trying to figure this one out.

I have a 2017 i7 iMac and it has a wired ethernet connection to a gigabit switch.

On the same network I have a WiFi enterprise mesh, both networks share a common DHCP server.

At some point in the past few months I enabled WiFi on the iMac, I think it might have been related to getting some features to work with AirPlay or my iWatch or something.... whatever.

I've noticed since that file transfers to my NAS have been slow. Interestingly enough, if I disable WiFi on the iMac temporarily then transfer speeds go through the roof and I get the performance I am used to.

A google search turned up articles in which people claimed that the Mac obeys the "Set Service Order" preference in system preferences -> Network area. I have that set with Ethernet as the top choice but my iMac continues to prefer the WiFi connection.

Does anyone have any other troubleshooting ideas on this one?

Thanks
Maybe I’m missing the point, but I have never had Wi-fi switched on in any of my iMacs connected by Ethernet. Why would you have it on?
 

Darmok N Jalad

macrumors 68030
Sep 26, 2017
2,803
11,847
Tanagra (not really)
Maybe I’m missing the point, but I have never had Wi-fi switched on in any of my iMacs connected by Ethernet. Why would you have it on?
You have to have it on for AW unlock, or at least so the Apple documentation claims. I suppose one could try disabling wifi to see if it still will work, as Bluetooth is the other requirement.

Thanks for taking the time to respond.

I have an enterprise grade network that presents the 2.4ghz and 5.0ghz network to the clients on the same SSID and the iMac is always connected to the 5.0ghz band.

There's no way I'm going to redesign a $1,000+ wireless network and split the 2.4ghz and 5.0ghz bands just because the iMac isn't working right.
Another tip I came across was disabling ipv6 on your Mac's ethernet, but that also seems like a long shot. Seems like most posts reporting similar problems as you come back unanswered.:(
 
  • Like
Reactions: BeatCrazy

jmpage2

macrumors 68040
Original poster
Sep 14, 2007
3,072
386
Go to Networks, then Wifi, and click the Advanced button.
Make sure the Wifi network that you expect is at the top of the list in Preferred Networks list.
You can delete any other items than the Wifi that you expect to use.
OR - you can delete all items, so the preferred items list is empty.

Maybe that will help make your connection what you might be expecting.
This makes absolutely no sense. What I expect is that both ethernet and WiFi are connected but the Mac prefers ethernet.
[doublepost=1526438992][/doublepost]
Maybe I’m missing the point, but I have never had Wi-fi switched on in any of my iMacs connected by Ethernet. Why would you have it on?
AirDrop and AW unlock don't work as far as I know without WiFi being enabled.
 

DeltaMac

macrumors G4
Jul 30, 2003
10,468
2,788
Delaware
This makes absolutely no sense. What I expect is that both ethernet and WiFi are connected but the Mac prefers ethernet.

AirDrop and AW unlock don't work as far as I know without WiFi being enabled.
Exactly. Leave Wifi enabled.
Make sure that service order has Ethernet first.
And, make sure YOUR wifi network is at the top of your Preferred Networks list. Delete all others in that list.

If you still struggle with your network connection, then it may be some configuration issue on your router.
Or, could it be a distance issue from the access point (maybe the mesh is not working properly, and you are connecting to a distant access point, and not the closest/strongest? A mesh system should take care of this transparently, but maybe there is some issue on the network setup.)

( Enterprise mesh? Is this an Ubiquiti setup? )

Finally, not a solution, but a work-around. Turn off your wifi card when you need to transfer files on the NAS.
Turn your wifi back on when you are done. That might be a simpler proposition than re-configuring your wifi network - when it may already be working properly.
 

Nugget

macrumors 68010
Nov 24, 2002
2,003
1,127
Houston Texas USA
Exactly. Leave Wifi enabled.
Make sure that service order has Ethernet first.
This is the correct answer. Interface priority is completely configurable from system preferences / networking.


make sure YOUR wifi network is at the top of your Preferred Networks list. Delete all others in that list.
This might not be desirable. WiFi networks are shared via iCloud to all devices, so clearing out all the other WiFi networks will propagate out to your iPhone and iPad and Apple Watch (if applicable) which might not be what you want at all. You’ll lose the WiFi at work and your favorite coffee shop and your friends house and other places where you want your mobile devices to connect automatically.

That might be part of keychain syncing, I’m not sure, but it’s likely to be enabled for someone and should be considered.
 
  • Like
Reactions: DeltaMac

flyinmac

macrumors 68040
Sep 2, 2006
3,576
2,452
United States
I haven’t tried with Apple watches and such (I don’t own them).

But... I always turn Wi-Fi off on my desktop computers. But I leave the settings on to sync with my iPhone over Wi-Fi and it works fine.

My computer is hardwired to the same SSID as my iPhone connects to via Wi-Fi.

The syncing always works automatically.

Personally, if it was me, I’d just give it a try. Worse case it doesn’t work, and you turn Wi-Fi on the computer back on.
 

imacken

macrumors 65816
Feb 28, 2010
1,232
124
The problem is that you need to have WiFi enabled in order to use Apple Watch unlocking or to use airdrop for file transfers.
Fair enough, I never use either of those, so wi-fi off has always worked for me.
 

Ifti

macrumors 68020
Dec 14, 2010
2,432
545
UK
I thought AirDrop used Bluetooth?
When I want to transfer images from my iPhone to my MacBook I have to switch on Bluetooth for it to work. With Bluetooth off you don't even see the MacBook as available when trying to transfer.
Then again this is to a MacBook where WiFi is always on anyways.....maybe it finds via Bluetooth but sends the files via WiFi?....
 

roadkill401

macrumors 6502
Jan 11, 2015
438
83
You are not alone. I have had the same issue and for the times that I needed to use wifi on for airdrop or some other stupid Apple requirement, then have to remember to turn it back off as it prioritizes wifi over a dedictacted ethernet connection. This I concluded was just another Stupid-Appleism.
 

Nugget

macrumors 68010
Nov 24, 2002
2,003
1,127
Houston Texas USA
I'm banging my head against a rock trying to figure this one out.
Just to bring this one to a close, OP, here's where you need to go to configure your iMac to behave the way you want. In the "Network" pane of the System Preferences App. Just drag the Ethernet interface up so that it is above the WiFi interface.

set service order.png
 
  • Like
Reactions: BeatCrazy

jmpage2

macrumors 68040
Original poster
Sep 14, 2007
3,072
386
Just to bring this one to a close, OP, here's where you need to go to configure your iMac to behave the way you want. In the "Network" pane of the System Preferences App. Just drag the Ethernet interface up so that it is above the WiFi interface.

View attachment 761921
I have already done that and it did not solve the problem. I did that before starting this thread.

Service order shows Ethernet 1st choice and then WiFi as 2nd choice.
[doublepost=1526491601][/doublepost]
Exactly. Leave Wifi enabled.
Make sure that service order has Ethernet first.
And, make sure YOUR wifi network is at the top of your Preferred Networks list. Delete all others in that list.

If you still struggle with your network connection, then it may be some configuration issue on your router.
Or, could it be a distance issue from the access point (maybe the mesh is not working properly, and you are connecting to a distant access point, and not the closest/strongest? A mesh system should take care of this transparently, but maybe there is some issue on the network setup.)

( Enterprise mesh? Is this an Ubiquiti setup? )

Finally, not a solution, but a work-around. Turn off your wifi card when you need to transfer files on the NAS.
Turn your wifi back on when you are done. That might be a simpler proposition than re-configuring your wifi network - when it may already be working properly.
The workaround is what I am doing.

Just to be clear, this issue has nothing to do with "configuration of your router" being wrong.

Or strength of WiFi signal to an access point.

Let me explain.

Router is 10.1.1.1/24
Mac Ethernet is 10.1.1.80
Mac WiFi is 10.1.1.125
Synology NAS is 10.1.1.3

There is no routing involved, at all when you connect from one of the interfaces on the Mac to the NAS... this is all done at layer 2 by way of ARP broadcast to find out where the device lives and then connecting to it directly over the ethernet/wifi fabric.

There is no routing.

The reason this kind of problem happens is that the Mac has a preference for sending the traffic out of one interface instead of another.

Does anyone know what preferences list can be deleted to force the Mac to look at the service order again? Does anyone know where in the BSD shell I can see how the Mac is handling the IP device list order?
 

DeltaMac

macrumors G4
Jul 30, 2003
10,468
2,788
Delaware
You can remove the network settings .plist file, reboot, then set up your network again (which would also include checking for the service order setup)
The good file to remove is in the /Library/Preferences/SystemConfiguration folder.
Trash the NetworkInterfaces.plist file.
Restart your Mac. Your Network pane will be reset to system defaults, so you would simply add your existing network connections. Related to that would be setting the Service Order, as it would also be at system defaults.
 

mmomega

macrumors demi-god
Dec 30, 2009
3,584
1,752
DFW, TX
Service order or nothing else I have come across will fix this issue, not yet anyway.

I keep wifi for my reason on as well as being connected on 10Gb fiber... every so often for no specific reason the Mac will just decide to use the wifi connection vs 10G, I let out a heavy sigh, go double check service order, restart, wifi off, yada yada yada. Nothing makes a difference.
If you want very specific Apple features then WiFi must be on which then means that the Mac will randomly choose which connection to use with zero basis on speed and healthiness of either network.
 

BurgDog

macrumors regular
Apr 22, 2012
217
178
Configure your wifi interface to a network address that is not in the subnet of the ethernet interface. WiFi/advanced/TCP-IP tab. Select manual and give manual IP. AW unlock still works and the WiFi is never used for network transfers. I have never found a solution where the ethernet interface remains primary if they are on the same subnet and this has been for few years on multiple Macs. Service order is supposed to solve this problem, but it doesn't. I think what is happening is on resume from sleep the wifi net comes up first sometimes and the system locks on using it as the primary even after the ethernet interface shows up.
 
Last edited:
  • Like
Reactions: Nugget

Fishrrman

macrumors Core
Feb 20, 2009
19,960
6,993
OP --

After you've tried all the good advice offered in this thread, and...
After you find that none of it works for you...
...I'd like to offer this suggestion:

Go with the simplest solution THAT WORKS for you.
Even if it seems "clunky".

That would be:
LEAVE THE WIFI TURNED OFF in the menu bar.
Turn it on ONLY if you really need to use it.
That will force EVERYTHING to use the ethernet connection.

Insofar as unlocking the computer with the watch goes, don't bother with it.
Just type in a password, and be done with it.

You're going to reply, "that doesn't solve my problem!"
No, but again...
When one way doesn't work, and no solution seems forthcoming, go a different way that DOES work.

That's about it...
 

jmpage2

macrumors 68040
Original poster
Sep 14, 2007
3,072
386
Configure your wifi interface to a network address that is not in the subnet of the ethernet interface. WiFi/advanced/TCP-IP tab. Select manual and give manual IP. AW unlock still works and the WiFi is never used for network transfers. I have never found a solution where the ethernet interface remains primary if they are on the same subnet and this has been for few years on multiple Macs. Service order is supposed to solve this problem, but it doesn't. I think what is happening is on resume from sleep the wifi net comes up first sometimes and the system locks on using it as the primary even after the ethernet interface shows up.
Thanks for the information. I don't see how having the Mac in an unserviced fictitious subnet with a static IP would fix anything since there would be no route to the rest of the network.... unless you are implying that it will make the Mac think that Air Drop and other features are available and instead use Ethernet for them. I certainly don't plan on splitting my network in order to create a new VLAN just for my iMac.

I might report this to Apple as a bug... maybe if enough people yell at them they will actually fix their software.
 

BurgDog

macrumors regular
Apr 22, 2012
217
178
Thanks for the information. I don't see how having the Mac in an unserviced fictitious subnet with a static IP would fix anything since there would be no route to the rest of the network.... unless you are implying that it will make the Mac think that Air Drop and other features are available and instead use Ethernet for them. I certainly don't plan on splitting my network in order to create a new VLAN just for my iMac.

I might report this to Apple as a bug... maybe if enough people yell at them they will actually fix their software.
It permits Apple Watch unlocking and location services to work and prevents any network traffic over Wifi and forces all traffic over ethernet which is what is desired anyway when you have both. Normally I'd just turn off wifi but need it on for unlocking and location services. I never want data to move over wifi when I have ethernet connected to the same network.
 

mj_

macrumors 6502a
May 18, 2017
984
585
Austin, TX
Having multiple interfaces in one network has always been troublesome with any UNIX/Linux system I am familiar with. Yes, it works most of the time but then occasionally there's issues such as the ones you're experiencing. BurgDog might be on to something - WiFi needs to be enabled in order to use the AW unlocking feature but as far as I know the interface doesn't even need an IP address, and it might not even need to be connected to any network at all. Before you manually edit your IP settings maybe give this a shot: disconnect from your home WiFi but leave WiFi enabled in general.

If that doesn't work and both interfaces need to be in the same network maybe you can use a static route forcing the Mac to connect to certain hosts through a specific interfaces. Assuming en0 is your wired NIC:

route add -host 10.1.1.3 -iface en0

I know this can be done on most UNIX and Linux systems but I haven't tried it on macOS/Darwin yet.
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.