KentuckyApple

macrumors regular
Original poster
Jul 2, 2003
160
55
Chicago, IL
i have a 2 month old i7 iMac. Today I moved my router across the house and the iMac is now using wifi instead of being plugged in. I have an ac1200 router that works great and my other devices can max out my 90mbit internet connection in the same room as the iMac. The iMac will only get max 60mbit, and usually less than that. I've tried resetting pram and SMC but nothing seems to work. I've had macs for 20 years and I'm stumped. the only thing I can think is that possibly one of the internal antennas is not connected. Any ideas?
 

komatsu

macrumors 6502a
Sep 19, 2010
539
44
First of all, if convenient get an ethernet cable and connect your iMac directly to your modem router. Then test the speed. This will help to narrow down the problem as to whether it it WiFi or Ethernet or Both affected by slowness.

Other things to try:

Go to folder:

Library/Preferences/SystemConfiguration:

and delete the following files:


com.apple.airport.preferences.plist
com.apple.network.eapolclient.configuration.plist
com.apple.wifi.message-tracer.plist
NetworkInterfaces.plist
preferences.plist

Reboot your iMac.

Then, go to Settings - Network panel and use the "-" sign to remove ALL networks.

Then go to Network panel and click on “Locations” followed by “Edit”. Click on the “+” and give your network location a new name like “Office Network 1”. Click on “Done” followed by “Apply”.
 
  • Like
Reactions: zipur
Comment

spencecb

macrumors 65816
Nov 20, 2003
1,062
84
I know this is a (somewhat) old thread, but I just got an iMac 27" Retina 5K last night and have been disappointed with the wifi speeds. I did a speedtest today on my iMac, iPhone X and iPad Pro. iMac was getting about 6mps and my iOS devices were getting just slightly above 80 Mbs. Needless to say this was pissing me off and knew the iMac was surely more capable. I followed your steps, and now it is getting 82 Mbps! Thanks for the tip!
Screen Shot 2018-04-24 at 10.07.35 PM.png
 
Comment

spencecb

macrumors 65816
Nov 20, 2003
1,062
84
You're more than welcome spence. Glad it worked for you.

Just out of curiosity (if you are still monitoring this thread), this seems to keep happening. I keep getting slow speeds and have to delete the plist files and also setup my network settings again. Have you found that this has occurred repeatedly?
 
Comment

spencecb

macrumors 65816
Nov 20, 2003
1,062
84
This method of fixing this WiFi is no longer working. The fact that I have to do it on a regular basis is frustrating on its own, but now my $2,500.00 iMac won't get internet speeds over 3Mbps but my $750.00 iPad Pro gets 82Mbps internet. This is driving me insane. Anyone know of a permanent fix? I am only about a month or so away from our home office being completed where I will have it plugged in via Ethernet, but this is just insane.
 
Comment

mj_

macrumors 65816
May 18, 2017
1,349
948
Austin, TX
From my experience 2.4 GHz Wi-Fi on Macs is broken beyond repair. If at all possible try using 5 GHz Wi-Fi (802.11ac), which should give you a much higher performance and a more reliable connectivity. Connected to my router's 5 GHz Wi-Fi my 2017 iMac can easily utilize the full 250 Mbps downstream my cable internet connection is capable of.
 
Comment

spencecb

macrumors 65816
Nov 20, 2003
1,062
84
I actually figured out part of the problem. We have a built-in wireless access point made by Ubiquiti that is very close to my iMac and an AirPort Extreme in the back of the house in the basement by all out network equipment. For some asinine reason, the iMac is connecting to the AirPort Extreme and not the Ubiquiti. As soon as I unplugged the Airport and deleted my network preferences (again, for the 900th time) and set it up again, it connected just fine to the access point that is right near it as opposed to connecting to the router clear on the other side of the house on a different floor. I'm hoping that now that it has connected to the Ubiquiti first, I can safely plug the Airport back in and it will no longer prefer to connect to that one...
[doublepost=1531255329][/doublepost]
From my experience 2.4 GHz Wi-Fi on Macs is broken beyond repair. If at all possible try using 5 GHz Wi-Fi (802.11ac), which should give you a much higher performance and a more reliable connectivity. Connected to my router's 5 GHz Wi-Fi my 2017 iMac can easily utilize the full 250 Mbps downstream my cable internet connection is capable of.

Yeah, I've heard this, too. See above for what I believe to be my problem. Our posts crossed.
 
Comment

mj_

macrumors 65816
May 18, 2017
1,349
948
Austin, TX
Yes, I saw that. There's an easy way to figure out which access point your iMac is connected to. When you option-click on the Wi-Fi symbol at the top right you'll get some stats. Among others the RSSI noise and the BSSID. The former gives you an approximation of the signal to noise ratio - anything above -70dBm (aka anything between -70dBm and -25dBm) is considered a good signal, -70dBm to -80dBm is still decent, and everything below -80dBm is too weak. The BSSID, on the other hand, is an identifier and tells you which base station your iMac is connected to. Take note of the BSSID and the RSSI now that the AirPort Extreme is off, then plug it back in and see whether your iMac will connect to the weaker signal again. If it does you'll see a much worse RSSI and a different BSSID than before.
 
Comment

KentuckyApple

macrumors regular
Original poster
Jul 2, 2003
160
55
Chicago, IL
I had wifi issues on my new iMac when I got it last year. I was going crazy trying to figure it out. My old 2009 iMac was able to saturate my internet connection but the new iMac would only get about half the speed and it was very erratic. I eventually tracked the issue down to a menu meter app I was using to display transfer speeds in my menu bar. I uninstalled it and things were much better. I will say however that wifi on the iMac is not great in general. When I plug into a router that has DD-wrt installed and is acting as my wireless client, I always can maintain 110mbit download. Using the iMac built in wifi it's never that good.
 
Comment

spencecb

macrumors 65816
Nov 20, 2003
1,062
84
Yes, I saw that. There's an easy way to figure out which access point your iMac is connected to. When you option-click on the Wi-Fi symbol at the top right you'll get some stats. Among others the RSSI noise and the BSSID. The former gives you an approximation of the signal to noise ratio - anything above -70dBm (aka anything between -70dBm and -25dBm) is considered a good signal, -70dBm to -80dBm is still decent, and everything below -80dBm is too weak. The BSSID, on the other hand, is an identifier and tells you which base station your iMac is connected to. Take note of the BSSID and the RSSI now that the AirPort Extreme is off, then plug it back in and see whether your iMac will connect to the weaker signal again. If it does you'll see a much worse RSSI and a different BSSID than before.


Hmmmm...I'm a little surprised at the results, then. I still have the Airport unplugged, and the Ubiquiti is less than 10 feet away, completed unobstructed. Here is what I am seeing, though:
[doublepost=1531258225][/doublepost]
I had wifi issues on my new iMac when I got it last year. I was going crazy trying to figure it out. My old 2009 iMac was able to saturate my internet connection but the new iMac would only get about half the speed and it was very erratic. I eventually tracked the issue down to a menu meter app I was using to display transfer speeds in my menu bar. I uninstalled it and things were much better. I will say however that wifi on the iMac is not great in general. When I plug into a router that has DD-wrt installed and is acting as my wireless client, I always can maintain 110mbit download. Using the iMac built in wifi it's never that good.

Yeah, I can't wait to get plugged into Ethernet just so I never have to deal with wireless on the iMac. There is no point to use WiFi if you have the option to plug in. All over our A/V equipment is hardwired, which leads to very little problems with all of it.
 

Attachments

  • Screen Shot 2018-07-10 at 4.27.23 PM.png
    Screen Shot 2018-07-10 at 4.27.23 PM.png
    25.4 KB · Views: 209
Comment

mj_

macrumors 65816
May 18, 2017
1,349
948
Austin, TX
An RSSI of -49dBm is excellent. In fact, the only way you'll get anything below 40 is when you're sitting right next to the Wi-Fi router, less than 3 ft away with a clear line of sight. It's a logarithmic scale, which means that it ain't linear in regards to distance and quality. A 10dBm difference equals factor 2x in signal to noise ratio.

In other words: -49dBm is between Very Good (-65dBm) and Amazing (-30dBm) and thus... well, what's between very good and amazing? Exceptional? :D
 
  • Like
Reactions: spencecb
Comment

spencecb

macrumors 65816
Nov 20, 2003
1,062
84
An RSSI of -49dBm is excellent. In fact, the only way you'll get anything below 40 is when you're sitting right next to the Wi-Fi router, less than 3 ft away with a clear line of sight. It's a logarithmic scale, which means that it ain't linear in regards to distance and quality. A 10dBm difference equals factor 2x in signal to noise ratio.

In other words: -49dBm is between Very Good (-65dBm) and Amazing (-30dBm) and thus... well, what's between very good and amazing? Exceptional? :D

Ok, good to hear! I haven’t plugged the Airport back in yet, and the biggest reason we have the second access point is for wireless speakers out back. When we move to our new house soon we are going to have Ubiquiti access points installed throughout. If you’ve never used their products, I highly recommend as they are extremely low maintanance and (as you’ve confirmed) work very well.
 
Comment

evands

macrumors member
Oct 23, 2001
90
1
Decatur, GA
Other things to try:

Go to folder:

/Library/Preferences/SystemConfiguration:

and delete the following files:

com.apple.airport.preferences.plist
com.apple.network.eapolclient.configuration.plist
com.apple.wifi.message-tracer.plist
NetworkInterfaces.plist
preferences.plist

Reboot your iMac.

Then, go to Settings - Network panel and use the "-" sign to remove ALL networks.

Then go to Network panel and click on “Locations” followed by “Edit”. Click on the “+” and give your network location a new name like “Office Network 1”. Click on “Done” followed by “Apply”.
I thought it was crazy this would help, but it was easy to give it a shot. My mother's 2017 iMac went from 50 msec ping, 4 mbps down, 9 mbps up to 11 ms ping, 94.9 mbps down, 11.8 mbps up (same test server) after clearing these preferences. Note that I've edited the quote above slightly -- the relevant folder is the root Library, not the user-level Library. Thanks, Komatsu!
 
  • Like
Reactions: komatsu
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.