2018 Mac Mini with Razor Core X - Is dual screens a requirement?

Discussion in 'Mac mini' started by Addman010, Jan 15, 2019.

  1. Addman010, Jan 15, 2019
    Last edited: Jan 15, 2019

    Addman010 macrumors newbie

    Addman010

    Joined:
    Jan 15, 2019
    Location:
    London, UK
    #1
    Hi guys, new here, i did spend some time looking to see if anyone else had already posted about this, and done the usual trawling through youtube etc.. so here goes.

    I've got a 2018 Mac Mini with an external GPU, a Razor Core X with a Radeon RX580.

    The issue i have is i don't seem to be able to find a way to run a single screen on my setup. The reason for this is when i boot the machine from cold having only a screen attached via the eGPU, i don't see the login screen. Therefore i've had to hook up a second screen (whihc i don't want) to the onboard HDMI port on the Mac Mini. Once the machine logs in, the eGPU screen appears and looks amazing!

    I've set the eGPU screen as the primary screen in the display settings within the Mac, but on reboot, it still needs a locally attached screen.

    IMG_2507.jpeg

    This is what i'm trying to avoid.
    IMG_2508.jpeg

    Any help would be greatly appreciated.
     
  2. dia3olik macrumors member

    Joined:
    Sep 14, 2007
    #2
    Try this:

    boot with internal gpu, then attach the egpu, attach the monitor to the egpu and make it primary, then detach the internal gpu monitor and reboot
     
  3. Addman010 thread starter macrumors newbie

    Addman010

    Joined:
    Jan 15, 2019
    Location:
    London, UK
    #3
    Hi, thank you so much for the suggestion. I've tried this without success.
    Do you have an eGPU yourself? Are you able to use a single monitor via your eGPU on reboot?
     
  4. KennethS macrumors regular

    Joined:
    Jan 4, 2011
    Location:
    UK
    #4
    It seems to be a common problem with the current macOS implementation of eGPUs. Do you have FileVault enabled? I do and need to enter my user password at the Mac login screen. I have my monitor connected to both the eGPU (via DP cable) and directly to the mini (via USB C). When I reboot my mini, I select the input from the monitor for the direct connection to the mini in order to see the login screen. It isn't 100% foolproof but usually works for me.
     
  5. Addman010 thread starter macrumors newbie

    Addman010

    Joined:
    Jan 15, 2019
    Location:
    London, UK
    #5
    That's a nice work around - i might do exactly this for the timebeing.
    I do have FileVault enabled at the momenet, is your thought to disable allowing auto login - thus removing the need for a second screen connection from the onboard gpu to view the password prompt screen?

    Screenshot 2019-01-15 at 12.32.02.png
     
  6. KennethS macrumors regular

    Joined:
    Jan 4, 2011
    Location:
    UK
    #6
    I opted for security over convenience so do not allow auto login. I haven't tried but it is logical to assume that enabling auto-login may get around the issue, but I am not certain. I make use of the USB A ports on the back of my monitor, and my understanding is it is advisable for me to have the mini directly connected to the monitor to have the ports passthrough to the mini anyway, so it doesn't bother me too much. The display issue is only an issue on mine when I reboot, which I rarely do anyway (I let it sleep when I am away from it).
     
  7. dia3olik macrumors member

    Joined:
    Sep 14, 2007
    #7
    I disabled FV. nowadays sensible data sits on the cloud...so...

    I had the same problem and I solved it doing what I suggested...it took a few tries tho...
     
  8. Addman010 thread starter macrumors newbie

    Addman010

    Joined:
    Jan 15, 2019
    Location:
    London, UK
    #8
    @dia3olik & @KennethS Thank you guys, really appreciate the time spent to help me further understand this challenge. Lets hope future updates resolve this niggle. For now, i'm going to double attach both eGPU and onboard GPU feeds to a single screen. Thank you!
     
  9. Addman010 thread starter macrumors newbie

    Addman010

    Joined:
    Jan 15, 2019
    Location:
    London, UK
    #9
    Actaully ended up disabling FileVault, removed locally attached monitor, and hey presto. It works perfectly... Now to get the new Vega VII :D
     
  10. F-Train macrumors 65816

    Joined:
    Apr 22, 2015
    Location:
    NYC & Newfoundland
    #10
  11. Addman010 thread starter macrumors newbie

    Addman010

    Joined:
    Jan 15, 2019
    Location:
    London, UK
    #11
    You are correct "If you have a Mac mini (2018) with FileVault turned on, make sure to connect your primary display directly to Mac mini during startup. After you log in and see the macOS Desktop, you can unplug the display from Mac mini and connect it to your eGPU"

    Thank you for sharing the link.
     
  12. tonyunreal macrumors regular

    tonyunreal

    Joined:
    Feb 25, 2010
    #12
    I have the same setup but even with FileVault turned off, macOS still sometimes boot to the login screen that the gpu can't display, ignoring the auto login preference in user settings. I don't what caused this but it seemed to do this more often on cold boot or when switched from boot camp. So far I had to force turn off the machine everytime it does this, and deal with the subsequent "reset password?" and "startup disk needs to be updated" screens that show up, which is super annoying, but at least I can get back to macOS from this.
     
  13. F-Train macrumors 65816

    Joined:
    Apr 22, 2015
    Location:
    NYC & Newfoundland
    #13
    I suggest that you read the link in post #10 and in particular the footnotes, especially foornote #3 on Boot Camp.
     

Share This Page