21.5" won't boot in 64-bit?

Discussion in 'iMac' started by britboyj, Jan 6, 2010.

  1. britboyj macrumors 6502a

    Joined:
    Apr 8, 2009
    #1
    I have the base 21.5" iMac (because hey, if I'd have got a machine with these specs six months ago, I'd have been paying $2400, graphics card aside, which I don't need for anything I do) and no matter what I do, I CANNOT get it to boot in 64-bit mode.

    Tried holding down 6 and 4 (unlikely to work since it's a BT keyboard after all) and tried modifying the boot plist. Still nothing. The Terminal command to check 64-bit extensions returns that it SHOULD be okay, but it says 64-bit extensions "no" in System Profiler.

    What gives?
     
  2. gibbz macrumors 68030

    Joined:
    May 31, 2007
    #2
    Does it matter? Not sure what the point would be unless you are trying to access tons of memory.

    64-bit mode just enables a 64-bit kernel. I don't think they have all of the extensions in 64-bit yet. You can still run all 64-bit capable apps with the default 32-bit kernel.

    according to here, it might not be supported right now.
     
  3. RealEvil macrumors 6502

    Joined:
    Aug 5, 2007
    #3
    It will make your system faster:
    http://macperformanceguide.com/SnowLeopard-Performance.html

    And the Apple chart be a lot clearer - but you do have a machine capable of using the 64Bit Kernel (at least you should... the 27" is and all current MBPs are... I cannot see why not)

    try typing in terminal:

    ioreg -l -p IODeviceTree | grep firmware-abi

    if it returns '"firmware-abi" = <"EFI64">' you are good to go. It should.

    Assuming you got the EFI64 value, type then reboot:

    sudo nvram boot-args="arch=x86_64"

    NOTE - you will lose this setting if/when you reset your PRAM.
     
  4. spacepower7 macrumors 68000

    Joined:
    May 6, 2004
    #4
    If I get this response does that mean I can run Windows 7 in 64 Bit ???
     
  5. RealEvil macrumors 6502

    Joined:
    Aug 5, 2007
    #5
    What? Have you been following this at all?

    You can use bootcamp to install Win 7 64 bit. Use the forum search.
     
  6. britboyj thread starter macrumors 6502a

    Joined:
    Apr 8, 2009
    #6
    Is this a better, worse or different than doing it by modifying the plist?

    EDIT: Tried this, still no dice. System profiler still says 64-bit kernels and extensions - No. Terminal DID return EFI64.
     
  7. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #7
    I don't know if this would prevent it from booting into 64-bit but would you have a firmware password by any chance?
     
  8. britboyj thread starter macrumors 6502a

    Joined:
    Apr 8, 2009
    #8
    I don't even know how to do, or check that. When I chance the plist I enter my admin password, same for entering the sudo command in terminal.
     
  9. RealEvil macrumors 6502

    Joined:
    Aug 5, 2007
    #9
    Its no better or worse except that you might reset your PRAM sometimes.

    So you got the EFI64 response? But the sudo command did not work (you gave your correct password right)? If those 2 statements are true, I suggest you ask someone else on this forum with a 21.5 to test this too but are you sure you typed it in correctly?
     
  10. britboyj thread starter macrumors 6502a

    Joined:
    Apr 8, 2009
    #10
    Found the problem!

    When I started the machine I restored from my MacBook Air's Time Machine backup, which contained two EFI firmware updates for the first-gen Air. Deleting these and resetting the PRAM allowed the iMac to boot in 64-bit. :)

    So for those getting new iMac's and transferring from old machines: DELETE YOUR OLD EFI UPDATES FROM THE NEW MACHINE.

    Thanks for the help!
     

Share This Page