24 iMac problem HELP PLEASE

Discussion in 'iMac' started by ChiNNeSSeeBoy94, Nov 25, 2009.

  1. ChiNNeSSeeBoy94 macrumors member

    Joined:
    Jun 30, 2009
    #1
    for some reason when i turn on my iMac its just a white screen. theres the noise but the apple logo does not pop up. what should i do to fix it?!
     
  2. mtnDewFTW macrumors 6502a

    Joined:
    Oct 26, 2009
    Location:
    California
    #2
    Got AppleCare?
    Call Apple.

    If not, I guess lesson learned, get AppleCare next time.
    LOL kidding, but seriously.

    Anyway, since you can't even get into the system at all, have you tried reinstalling the OS?
     
  3. fluffyx macrumors 6502

    Joined:
    Oct 25, 2007
    #3
    If you take your computer to the Genius Bar at Apple, they'll boot it from an external drive and take a quick look at things to try and determine what's wrong.

    The most likely scenario is either a damaged operating system, a failed hard drive, or a defective optical drive flex cable.

    Try leaving it on for 10 minutes or so. Does a flashing question mark eventually appear? If you see a flashing question mark, but it takes a minute or more to appear, it's almost certainly a failed hard drive or a defective flex cable.

    (tech note: if a device on the ATA chain fails to respond to the computer's signals, the system may hang at a blank white screen for several seconds to several minutes while the system waits for a response. the optical drive flex cables on some glass imacs are defective, resulting in this "blank white screen" symptom)
     
  4. Carolus Rex macrumors newbie

    Joined:
    Nov 26, 2009
    Location:
    Stockholm
    #4
    There are a few things you can do yourself first; 1) on startup, do you hear the chime/chord? Press and hold down "alt" ":apple:" "p" and "r" until you hear the chord for the SECOND time, then release. Better now? If not then 2) try first and boot it from the install Dvd. Press "C" during startup. If this works it is most likley software related. If not, it is probably HW. If it is in warranty you will have it repaired at no cost.
     

Share This Page