24" LED Cinema Display, 2 outer USB ports aren't working

Discussion in 'Mac Accessories' started by davidg4781, Jul 10, 2015.

  1. davidg4781 macrumors 68020

    Joined:
    Oct 28, 2006
    Location:
    Alice, TX
    #1
    I found a really good deal on a 24" LED Cinema Display on CL. I got it home, it looks nice and all. Everything works except the two outer USB ports. I've tried this connected to both of my MBP's USB ports and one on my new (to me) mini.

    It looks like the inside one might work as it makes an external drive's light flicker, but won't read it. Middle one seems to work fine. It's not a power issue, I don't think, because a USB keyboard won't work on them either.

    Is there a way to reset firmware or is this maybe a known issue for this or do I just do without? I really don't care for them back there since they're a bit of a hassle to get to.
     
  2. kohlson macrumors 65816

    Joined:
    Apr 23, 2010
    #2
    I need to ask the obvious "is it plugged in?' question. Do these ports show up in About this Mac-System Report?
     
  3. davidg4781 thread starter macrumors 68020

    Joined:
    Oct 28, 2006
    Location:
    Alice, TX
    #3
    It's plugged in. I'm using a USB keyboard attached to the middle port.

    Where would I go to see if the other two show up? I tried looking through System Information but nothing showed LED Cinema Display > 3 USB Ports.

    The hub on the keyboard show up along with the hub on the display, just not an actual number of ports.
     

Share This Page