27" 2010 iMac- No sound/Chime

Discussion in 'iMac' started by orbytel, Jul 30, 2016.

  1. orbytel macrumors newbie

    orbytel

    Joined:
    Jul 30, 2016
    #1
    Hi all,
    I was hoping someone could provide some suggestions on how to resolve a sound issue I'm having, as I've exhausted all other avenues, for my 11,3 27" 2010 iMac.

    A little while ago, out of the blue, all sound stopped playing. There is no startup chime, no sound through the internal speakers, and no sound through the headphone out.

    After scouring the net I've found a number of posts from people who have no sound on my model- which s usually due to the internal sound disappearing from the Sound settings. However- my issue is a little more unique.

    The internal sound is set as the output in the sound settings and, as far as the OS is concerned, it is playing through the internal speakers or headphone out. Volume control works fine, and I can set the internal sound through audio MIDI setup etc. What's even stranger is that, when I plug in headphones, I get the static crackle, and the OS detects that headphones are connected. This led me to believe that it wasn't a hardware issue, yet anything that I have tried has failed to resolve the issue.

    I've tried the following:
    *Reset the SMC and Pram multiple times
    *Following all the steps listed here: https://discussions.apple.com/thread/7368631?start=0&tstart=0
    *Jiggled a a 3.5mm jack in the headphone port (this was a common fix for people who's volume bar greyed out, or couldn't disable sound output to headphones due to the internal 'switch' on the jack failing to turn off).
    *Reinstalled the OS
    *Installed a completely new HDD, with a new OS from scratch
    *Inspected the logic board for any evidence of hardware issues (apart from some chalking, which I cleaned up with an alcohol wipe, the board looks immaculate with no evidence of damaged capacitors or lifting of any components)
    *Replaced the internal Headphone/Mic port and ribbon cable assembly
    *Tested sound output via USB which works fine (as you'd expect)

    I'm now a little torn, as I don't think its a hardware issue. If it were a PC, I'd be assuming that there was a firmware/bios issue, and the next step I'd take would be to reflash the bios... However, from what I've seen, I can't forcibly reflash here. My boot ROM version is up to date (IM112.0057.BO3), and the SMC version is 1.59f2

    At the moment I'm just using a USB hub with a 3.5mm in/out, but I'd really like to get my internal speakers working again. Any help would be greatly appreciated!
     
  2. Dreadnought, Jul 31, 2016
    Last edited: Jul 31, 2016

    Dreadnought macrumors 68020

    Dreadnought

    Joined:
    Jul 22, 2002
    Location:
    Almere, The Netherlands
    #2
    My first thought was the headphone port, but you already looked at that. Do you have audio with headphones?

    Usually resetting the PR ram fixes these kind of strange bugs. But you also already did that...
     
  3. orbytel thread starter macrumors newbie

    orbytel

    Joined:
    Jul 30, 2016
    #3
    Cheers for the reply. I thought the same, regarding the headphone port. I replaced it with a used one from eBay, which was sold 'as-is', so I'm wondering if perhaps I was sold another bad one. Unfortunately, I don't have another 11,3 to test either headphone port on.

    Do you think it'd be worth trying to track down another? The next step would be tracking down a replacement logic board, but that's the last resort- as I'd be dropping another $200 on it.
     

Share This Page