27" 2012 imac - screen stuck @ 640x480 resolution

Discussion in 'iMac' started by macuserau104, Feb 23, 2013.

  1. macuserau104 macrumors newbie

    Joined:
    Jan 31, 2012
    #1
    just unboxed my new 27" 2012 imac - after a 6 week wait for it to arrive.

    first thing i did was run time machine to back it up on a new external 3TB HD.

    it went to sleep during this and when i the screen opened up again the resolution is now stuck @ 640 x 480 i have tried all i can think of to resolve this with nil result.

    i cant contact apple as it is the weekend here (australia) and have done a few searches on the net with no result

    can any one help ?
     
  2. harlex macrumors member

    Joined:
    Nov 23, 2011
  3. lali macrumors regular

    Joined:
    Oct 14, 2007
    #3
  4. macuserau104 thread starter macrumors newbie

    Joined:
    Jan 31, 2012
    #4
    more info

    thanks for the help

    have been using 10.7.5

    mew mac shipped with 10.8.2 - tired restart, nil result

    display pref only allows either:

    - best fo display / scaled - it is stuck on best for built in display and if i choose scaled is back to best for built in display when i open it again
     
  5. drambuie macrumors 6502a

    Joined:
    Feb 16, 2010
    #5
    What's weird is that 640 x 480 isn't an available option. The smallest scaled resolution is 800 x 600. It's like you have no video drivers installed, and it's fallen back to the VGA default of 640 x 480.

    I notice you mention 10.7.5. I hope you didn't install that on your new iMac, as you would then have no drivers for the nVidia 6XX GPU.
     
  6. seanm9 macrumors regular

    Joined:
    Dec 29, 2007
    Location:
    Cape Cod, MA
    #6
    I had a similar issue, try booting from the recovery partition... if the resolution is still the same it may be a hardware failure... also if you haven't reset the SMC and Zap the NVRAM...
     
  7. WilliamG macrumors 604

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #7
    I'd do a complete wipe of the system at this point, and reinstall the OS. Just start from scratch. Something software-wise got a little screwy, that's for sure.
     

Share This Page