27'' iMac having graphic issues? (running win 7)

Discussion in 'Mac Basics and Help' started by armedwithturtle, Feb 23, 2013.

  1. armedwithturtle macrumors newbie

    Joined:
    Feb 23, 2013
    #1
    Hey guys, came across this site recently and it seems like you guys are great at resolving issues so hopefully you can help with mine

    I have a 27'' iMac that is 2 years old; the specs are

    Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz (8 CPUs), ~3.4GHz
    8GB Ram
    1TB HD
    AMD Radeon HD 6970M
    Windows 7 Ultimate 64-bit
    Boot Camp 3.3
    I also have the latest catalyst control center (if that means anything)

    my issue is that on occasion whenever I'm playing games (Civilization 5, Fifa 13, football manager 2013) the screen will just freeze and the screen would look similar to this and the fan would get noticeably louder; the computer is completely frozen and nothing on the keyboard works
    [​IMG]

    this is happened to me a lot though, and sometimes the screen has different colours (the other day it was a solid teal with brown lines, before that tan with black lines, etc). I was thinking I might be playing on too high settings (even though i've played pretty much max on all these games...) but it even happens to me when I watch videos on netflix.

    Is this fixable? Hopefully it's nothing pricey...

    thank you guys!
     
  2. Swiss-G macrumors 6502a

    Swiss-G

    Joined:
    Jun 3, 2010
    Location:
    United Kingdom
    #2
  3. dman71960 macrumors newbie

    Joined:
    Feb 23, 2013
    #3
    Hello, registered a new account to post this. mom had same issues turned out to be her graphics card was going bad. if you have applecare take it to the store.
     
  4. armedwithturtle, Feb 23, 2013
    Last edited: Feb 23, 2013

    armedwithturtle thread starter macrumors newbie

    Joined:
    Feb 23, 2013
    #4
    I'm running OS X 10.7.5 but can't seem to update my bootcamp to 4.0. After running software update is says everything is up to date and I can't find a 4.0. download anywhere online...

    thanks, if none of the suggestions work, i might have to do that

    edit - found windows files for boot camp... currently downloading that now, will update with results
     
  5. armedwithturtle thread starter macrumors newbie

    Joined:
    Feb 23, 2013
    #5
    The update for bootcamp 4.0. went well, everything is updated... The issue occurs still but only a bit later than before - I think I might have to take into the apple store
     
  6. exxo macrumors newbie

    Joined:
    Sep 14, 2011
    #6
    Have the same problem, I'm taking my 27" to the shop this week, no warranty left so I guess a new ati card will cost some $$$ :(
    I have the same problem in both osx and windows.
     

Share This Page