27" iMac i7 + Bootcamp and display driver crashing

johnrs

macrumors 6502a
Original poster
Jul 7, 2008
527
9
Nottingham - UK
Sorry if this has already been posted. Spent the past 30 mins looking and could not see anything.

Got myself a 27" iMac i7 which was delivered today.

Been playing with it all day in OSX and initially installed Win7 but I the display driver keep crashing and I was getting artifacts on screen then the message saying that it had recovered successfully.

Having read that Win7 was not fully supported I assumed that this was the problem so installed Vista, but got the same problem.

Screen stalled, then goes blank for a second and then the error message in the task bar.

I have just ran all the MS updates and also installed the latest GFX driver from ATI to see if that makes a difference.

I have also just ran 3dmark06 and that ran OK but I was expecting the fans to kick in at some point

Anyone else experienced anything like this

Cheers
 

taurapo

macrumors newbie
Nov 19, 2009
8
0
I have this exact same problem on vista 64, sometimes the driver refuses to restart and results in a BSOD.

the problem usualy presents itself when watching a movie, though it is yet to happen while playing games.
 

johnrs

macrumors 6502a
Original poster
Jul 7, 2008
527
9
Nottingham - UK
All i did was open control panel. 3dMark ran OK and I was expecting that to crash halfway through.

I was starting to panic thinking that it was faulty :eek:

Did not have much time to play after updating and running 3dmark so i will have another play tonight and see what happens
 

cvjvs

macrumors newbie
Nov 19, 2009
2
0
ati driver

seems these guys had the same problem, hope that helps.

HTML:
http://www.pcpro.co.uk/blogs/2009/10/26/how-to-install-windows-7-onto-the-new-27in-imac/
 

JohnKorn

macrumors newbie
Nov 19, 2009
9
0
I bought a Blu-ray drive for my Imac27inch core i7 Expecting it to play in Snow leopard, it appears mac are to cheap to buy rights for us to play bluray so i figured surely 3rd party software out to play blu-rays right ? WRONG!

Fine

I installed the following os and versions

Windows xp
Windows Vista 32 /64
Windows 7 32 / 64

all suffer from video card Drive issues - driver issue

However windows xp doesnt crash it does however display annoying colours pink / green lines ect.

NOT HAPPY !
 

taurapo

macrumors newbie
Nov 19, 2009
8
0
i think might have found a solution,

i went to http://www.driverheaven.net/modtool.php downloaded the program and followed the steps up until step 5

after that i opened the device manager and
1: rightclicked the "ATI Radeon HD 4850" device and selected "update driver software"
2: chose the "browse my computer for driver software" option
3: chose "let me pick from a list of device drivers on my computer" option
4: clicked the "have disk" button and pointed it to the folder with the modified driver
5: and let it install

one reboot later and i have been able to watch a 2 hour movie in windows without a single driver crash (so far)

hoped this helps someone out
 

taurapo

macrumors newbie
Nov 19, 2009
8
0
Unfortunately i just had it crash on me again so feel free to disregard my previous post
 

johnrs

macrumors 6502a
Original poster
Jul 7, 2008
527
9
Nottingham - UK
I have installed win7 again & installed the official ATI drivers but not really played with it to much (work and stuff getting in the way)

Looking for a good temp monitor for windows 7 that will allow me to monitor CPU but more importantly the GPU as I wanted to see if it was over heating in windows.

I used to get this problem when I had my PC and overclocked the graphics card just that little too much...

If anyone know a good temp monitor that works in windows and can monitor both CPU & GPU could you post a link.

Cheers
 

taurapo

macrumors newbie
Nov 19, 2009
8
0
ATI released new drivers a couple of days ago wich seem to work

i uninstalled the "ATI Radeon HD 4850" drivers then installed the UNmodified new ones
i also noticed new audio device drivers got installed named "ATI High Definition Audio Device" i disabled those drivers and rebooted.

Been running rock solid ever since.

and to the poster above me try http://www.almico.com/speedfan.php
 

johnrs

macrumors 6502a
Original poster
Jul 7, 2008
527
9
Nottingham - UK
they are the drivers that I have intsalled so I am hoping that they make a difference too.

Just got to get the bloody wireless keyboard to work now..
 

taurapo

macrumors newbie
Nov 19, 2009
8
0
i have played some games on it (fallout 3, world of warcraft, killing floor) and have yet to run into any problem before, during or after gameplay.

as far as i can tell my issue is fixed
 

bulldogg80

macrumors member
Sep 9, 2009
47
1
hmm I have the same problem, i have only try in vista! the driver crash all the time. where do i find the UNmodified drivers?

sorry my English! need your help!:apple:
 

SlappyWhite

macrumors newbie
Dec 4, 2009
11
0
not working

Thanks! I have try it and it says Driver version 8.671.0.0 and driver date 2009-11-04 hmm sounds wrong, what is your version?
Same here. I downloaded the drivers from ATI's site and it clearly stated the date as 11/17/2009. Then after I've installed them it says the driver date is 2009-11-04 in Device Manager.

Not only that but the "new" driver set me back even further. When I rebooted after the install my screen went back being completely black again. I liked the flickering artifacts better.

taurapo, can you please check the driver date in the Device Manager?
 

bulldogg80

macrumors member
Sep 9, 2009
47
1
Same here. I downloaded the drivers from ATI's site and it clearly stated the date as 11/17/2009. Then after I've installed them it says the driver date is 2009-11-04 in Device Manager.

Not only that but the "new" driver set me back even further. When I rebooted after the install my screen went back being completely black again. I liked the flickering artifacts better.

taurapo, can you please check the driver date in the Device Manager?
yeh seems strange to me, should be nice if taurapo can post the driver version from Device Manager
 

johnrs

macrumors 6502a
Original poster
Jul 7, 2008
527
9
Nottingham - UK
I am not getting as many problems as I used to. Games seem to be OK, but when I do exit from a game such as COD my screen shifts down, so the bottom half of the screen moves off the bottom and appears at the top .

I will try and upload a photo of it when it happens again
 

AdmiralKristov

macrumors newbie
Dec 6, 2009
5
0
Hi all,

I was having the same driver crashing issue. I tried it on Windows 7 and both 32- and 64-bit versions of Vista, all came up with the "display driver stopped responding" popup.

I tried reinstalling the boot camp drivers and still had no luck. I then called Apple Support and the guy I got said I needed a new OS X disk and sent it out. I installed the drivers off the new DVD and have not had a problem since.

I am wondering if the rapid diagnosis I received from Apple Support means that there is a batch of corrupted installation media out there that they are aware of...

AK
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.