27" iMac not importing photos from D700

Discussion in 'iMac' started by powerhouse7, Mar 11, 2010.

  1. powerhouse7 macrumors regular

    Joined:
    Oct 21, 2009
    Location:
    Canberra, Australia
    #1
    Hi,
    Recently, I received my iMac 27" i7, 8GB RAM with the ATI Radeon HD 4850 Graphics Card.
    All was going well (well-ish. Got the 27" yellowing fever, but i'll worry about that later) until I tried to import photos from my Nikon D700 DSLR Camera.
    I plug the camera into the computer as I have always done with my previous mac but the computer doesn't mount the camera so I can import things. I tried importing with Nikon's Tranfer Software, Adobe Lightroom, and iPhoto and none of them recognised the camera.

    I know the camera isn't the problem because I can still import from the camera to another iMac ('07 or '08 model i think).

    What can I do to fix the problem?

    The computer that will import is running the latest version of Leopard, with an Intel Core 2 Duo processor. My 27" is running the latest version of Snow leopard.

    Thanks for any help.
     
  2. unamused macrumors 6502

    Joined:
    Oct 25, 2009
    #2
    subscribed!

    I have a d700 and looking to pick up an imac down the road as well...
     
  3. powerhouse7 thread starter macrumors regular

    Joined:
    Oct 21, 2009
    Location:
    Canberra, Australia
    #3
    I think the problem may have been a one off. I just did an import and my imac recognised it? Very odd.
     

Share This Page