27-inch, Late 2012 iMac 3TB Fusion Drive Problem

Discussion in 'iMac' started by doftin, Feb 1, 2014.

  1. doftin macrumors newbie

    Joined:
    Feb 22, 2013
    #1
    Hi Guys,
    I am having problem with my 3TB Fusion drive. When i bought it, i divided fusion drive to 2 partition half and half. Right now, i am trying delete second partition which i don't need any more but i couldn't do it. I tried everything but no luck. All options are grey out so i can't choose anything. Do you guys have any suggestions?
     
  2. hfg macrumors 68040

    hfg

    Joined:
    Dec 1, 2006
    Location:
    Cedar Rapids, IA. USA
    #2
    AFAIK ... the only "legal" way to partition a Fusion hard disk is with the BootCamp Assistant (without breaking the Fusion first, partitioning, and then rebuilding it). You would then, again, use BootCamp Assistant to remove that non-Fusion partition and restore the full capacity to the Fusion drive. You can use the partition any way you want, it doesn't have to be for Windows installation, and it is no longer a part of the Fusion management (good for static files such as large videos).

    How did you partition it?
     
  3. doftin thread starter macrumors newbie

    Joined:
    Feb 22, 2013
    #3
    I partitioned it with disk utiliy. And to be honest, i still didnt understand how fusion drive works.However, i found this solutuon and worked for me. Thanks for responding, i appricae it.

    Here it is:

    Go to Terminal under OS X Internet Recovery (Cmd-Opt-R)
    Enter - diskutil CoreStorage list
    Identify disk's numeric serial number
    Enter - diskutil CoreStorage delete <serial number>

    After this, open Disk Utility again and a box should pop up asking if you want to fix the drives in red text.
    Fix, then reinstall OS X.
     
  4. marzer macrumors 65816

    marzer

    Joined:
    Nov 14, 2009
    Location:
    Colorado
    #4
    For future ref, this thread helped me a lot in managing partitions in a Fusion environment. Esp. jedib0p's input. Once you get the hang of it you'll be able to add and delete multiple partitions without having to reload your system.
     

Share This Page