27" mac internal hard drive issue

Discussion in 'iMac' started by Wheresjerry, Feb 22, 2017.

  1. Wheresjerry macrumors newbie

    Wheresjerry

    Joined:
    Jan 2, 2016
    #1
    hey folks,



    talked with support yesterday for a few hours. Problem is, I can not get my internal drive to unmount. Upon start up, it keeps getting hung up when it shows progress bar and apple logo....itll get part way loading, then restarts.....fortunatly, I had a back up on time machine, and copied that to un external usb drive...phew, I have computer.



    Now, when I try to run First Aid in Disk Utilities, it spits out an error that says it can not unmount drive. Tried Erase, same thing, tried Verify Disk, on and on, we tried it all, right on up to Senior Tech guy....a couple plug tricks, and key strokes, but the same thing....Can Not Unmount Drive. His suggestion was to bring it in to an Apple Store and have them take a look at it. He said it could be a few things, Malware, failing Hard Drive, or loose wire....well, I doubt it could be a loose wire, a failing HD, possibly, though its only about 16 months old, Malware, you never know it always seems to find its way in I guess....



    Im reluctant to bring it in to The Apple Store, especially since I do have the computer to use. Only to say they could fix it by running this program ??, or Terminal command, etc.....so here ya go, what can I do that might not have been tried yet. Tech did not have me run any Terminal commands, so is this a possibility? Is there a virus program that can get right into the boot up area?



    Any help would be great......if I need a new HD, I have a late 2014 27" Running Sierra ....processor 3.5 GHz Intel Core i5

    memory

    16 GB 1333 MHz DDR3





    karl
     
  2. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    You can't "unmount" a drive while you're booted from it.
    It's that simple.

    I you need to unmount a drive, you have to boot from A DIFFERENT drive (such as an external).
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    Just so I am clear here... you restored your TM backup to an external USB drive and you are booted to that? If that is the case and you still cannot unmount or repair the internal drive, I'd say you have a failed internal drive.

    It is very unlikely any malware would do this and those iMacs have not been prone to have cable failures, particularly at 16 months old.
     
  4. Samuelsan2001 macrumors 604

    Joined:
    Oct 24, 2013
    #4
    Sounds like the drive has died, age means nothing any electronic component can die at any time for any numbers if reasons.
     
  5. Wheresjerry thread starter macrumors newbie

    Wheresjerry

    Joined:
    Jan 2, 2016
    #5
    That's what im leaning toward is that the hard drive has failed. Prior to this all happening when I rebooted my computer at one point the date and time were not correct
     

Share This Page