2G 2.1 custom ipsw request

Discussion in 'Jailbreaks and iOS Hacks' started by odotan, Mar 6, 2009.

  1. odotan macrumors newbie

    Joined:
    Nov 26, 2008
    #1
    I need help from you guys. Here's the situation:

    Before I start, let me note that I've been working with iPhones from day one and I have gone over all the basics (and the not-so-basics), so it's not the simple stuff that's the problem here.

    I have a 2G iPhone with a strange behavior that it will only accept 2.1 firmware (stock or custom). Any other version gives an error (ie. 1604, 20, 21) both from DFU and from restore mode.

    I do have a custom ipsw for 2.1 which would unlock the phone for me, but the problem is that the phone is already unlocked, and when BootNeuter runs, it sees that the settings already match and it reboots. This is not good for me because I DO want BN to do something. The reason behind that is that once the phone reboots, it freezes after about 5 seconds. What I would like to try is have BN run again only this time make at least one change to the settings so that the settings do not match the BB and therefore it is re-written.

    I have attempted making my own such such ipsw, but for some reason the phone keeps rebooting after being restored with it (I get the apple logo and a reboot after 30 sec or so). I have tried formatting my mac to 10.5.2 (which came with it originially, it's a MBA from the first gen, so the DFU issue of 10.5..5/10.5.6 is not an issue). I do not know why my ipsw's give me the continuous reboot, but hopefully someone else can create one for me which won't do that.

    The current BN settings are

    BL 3.9
    neuter on
    fakeblank off
    unlock on

    (same as here: http://wikee.iphwn.org/_media/sgold_bootrom:bn20.png? )

    I would like to request someone to create a custom ipsw of the 2.1 2G firmware with the following settings:

    BL 4.6
    neuter on
    fakeblank on
    unlock off

    This, so that BN is forced to reflash the BL and the BB.

    Please someone upload to Rapids*are a custom ipsw for me and post the link here. Please also do not use custom logo's (although it's really not an issue).

    Your help and attention is greatly appreciated, have a good weekend for now :)
     
  2. michael.lauden macrumors 68020

    michael.lauden

    Joined:
    Dec 25, 2008
    #2
    while i can't give you info on that

    i recommend to just upgrade to Apple's 2.2.1 straight from iTunes

    and then upload the jailbroken version to you iPhone.


    IMHO 2.2.1 is the most hassle free to jailbreak.

    i tried to restore to other's pre made ipsw's and it gave me nothing but troubles.. :confused:
     
  3. odotan thread starter macrumors newbie

    Joined:
    Nov 26, 2008
    #3
    Can't do that. get error 1604. Only 2.1 restores successfully.
     
  4. michael.lauden macrumors 68020

    michael.lauden

    Joined:
    Dec 25, 2008
    #4

Share This Page