2G iPhone stuck on screen with Apple logo - help!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by dysania, Jul 30, 2010.

  1. dysania macrumors newbie

    Joined:
    Sep 29, 2008
    #1
    I have a 2G iPhone which was hacked to work with UK Vodafone. All was well until I reset all the settings today. At the end of the reset process (using the "general" section of settings) it has become stuck with the apple logo. The phone is unresponsive including all buttons. My mac doesn't recognise it when connected by usb. Google has not been helpful either.

    I am lost for potential solutions and was hoping someone might be able to help.

    Thanks!

    D
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    You need to restore in DFU mode, but you'll lose the hack, whatever it is. It sounds like you erased all content. Don't do that ever again.
     
  3. RRmalvado macrumors 6502

    Joined:
    May 27, 2010
    #3
    It's weird how people say they have tried a google search and that they had no luck.
    I went to google and typed in the exact words of the title of this thread:

    "2g iphone stuck on screen with apple logo" with no quotes

    the FIRST link is to a thread here in the forums and post #9 offers the solution:
    http://forums.macrumors.com/showthread.php?t=334220
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Bad idea to erase all content and settings.
    Like aggie said DFU restore thru itunes.
    Then you will need to JB and unlock it again.
     
  5. dysania thread starter macrumors newbie

    Joined:
    Sep 29, 2008
    #5
    Thank you

    Problem solved with your help.

    Many thanks!
     

Share This Page