2nd display not working w/ MiniDisplay Port (e2008 MP)

Discussion in 'Mac Pro' started by kirkbross, Dec 31, 2014.

  1. kirkbross macrumors 6502a

    kirkbross

    Joined:
    Mar 6, 2007
    Location:
    Los Angeles
    #1
    Added a 2nd Dell 2007FP to my set up and it doesn't work.

    Display 1 is on the DVI and works fine, display 2 (identical monitor) is on one of two MiniDisplay Ports and it does not work. The display says "Out of range signal. Cannot display this video mode. Go climb a rock." message.

    2008 Mac Pro
    Mavericks
    ATI Radeon HD 5770 (Mac Edition from Apple).

    The cable is a brand new MiniDisplay Port-to-DVI cable I got from Monoprice.

    Thoughts?
     
  2. phairphan macrumors 6502a

    phairphan

    Joined:
    Sep 21, 2005
    Location:
    Reject Beach
  3. kirkbross thread starter macrumors 6502a

    kirkbross

    Joined:
    Mar 6, 2007
    Location:
    Los Angeles
    #3
    Yes. It shows up in settings and I can rearrange the monitors and move the control bar between the two displays, but the MiniDisplay Port monitor remains black.
     
  4. phairphan macrumors 6502a

    phairphan

    Joined:
    Sep 21, 2005
    Location:
    Reject Beach
    #4
    Hmm... In my experience these passive adapters are a bit of a crapshoot. You might want to try changing the output resolution from the native 1600x1200 to something lower to see if it triggers the display.

    I suspect the dual mode signal being sent out just isn't strong enough to drive this particular display. If so, the solution will be to use an active mDP to DVI adapter. Apple has one, of course, but Monoprice sells them too.
     
  5. kirkbross thread starter macrumors 6502a

    kirkbross

    Joined:
    Mar 6, 2007
    Location:
    Los Angeles
    #5
    I ordered an adapter off Newegg and that did the trick. Thanks.
     
  6. phairphan macrumors 6502a

    phairphan

    Joined:
    Sep 21, 2005
    Location:
    Reject Beach
    #6
    Glad to hear! I miss straight-up DVI.
     
  7. kirkbross thread starter macrumors 6502a

    kirkbross

    Joined:
    Mar 6, 2007
    Location:
    Los Angeles
    #7

Share This Page