iPod touch 2nd generation update?

CBillups1

macrumors 6502a
Original poster
Sep 1, 2008
685
36
Michigan
when i plug my brothers 2nd gen ipod touch its on some old software. 2.0? how do i get 4 or 5 on it?
 

AdrianK

macrumors 68020
Feb 19, 2011
2,230
1
You can't get iOS 5 on it, the last update for the second gens is 4.2.1.

Just plug it in to a computer running iTunes, select the iPod on the left hand side and click update.
 

CBillups1

macrumors 6502a
Original poster
Sep 1, 2008
685
36
Michigan
You can't get iOS 5 on it, the last update for the second gens is 4.2.1.

Just plug it in to a computer running iTunes, select the iPod on the left hand side and click update.
i clicked update but it says 2.2.1 is the current software.

and damn i wanted to download an app but on the iphone it requires 4.3 so im guessing it wont work :(

----------

actually i think it might be first generation lol
 

nickn

macrumors 6502
Jun 17, 2011
386
0
What generation is the iPod? The first gen does not have a speaker and is limited to 3.1.3. You can get that through a paid upgrade. The 2nd gen does have a speaker, and is limited to 4.2.1. Please post a definite answer to what you have.
 

Ivan P

macrumors 68030
Jan 17, 2008
2,695
4
Home
How to distinguish between a 1st and 2nd gen iPod touch:

1st gen:



Black aluminum border at the very edge of the screen
No speaker (just a clicker that plays basic sound effects for locking/unlocking)
Backplate is completely flat
Wi-fi antenna is rectangular, in very corner of device
No volume buttons

2nd gen:



Curved backplate that curves around to the front of the screen
In-built speaker
Wi-fi antenna is a stretched oval, located near the corner of the device
Volume buttons
 

APlotdevice

macrumors 68040
Sep 3, 2011
3,120
3,759
whats white door? i mean i just want to download an app, i dont really care if its slow.
WhitedOOr is custom firmware for the first and second generation iPod touch (as well as the iPhone 2G/3G) that gives you many of the features available in newer iOS releases. However from what I understand it won't let a first generation run apps which require iOS 4.0 or later.