2nd HDD 1TB on Early 2011 MBP faulty function

Discussion in 'MacBook Pro' started by riggidy, Jan 25, 2014.

  1. riggidy macrumors newbie

    Joined:
    Apr 30, 2013
    #1
    Hi, just installed a 2nd HDD (1TB hitachi) with a caddy instead of the optical drive and it doesn't work, I have an early 2011 MBP 15".
    1st I had hard time formatting it, it formats the drive only after a few times, after that the drive is really slow, it says stuff like "3 days left" for a 7GB file transfer, and not only that, after a reboot the drive doesn't mount and needs to be formatted again, now I'm going through this whole process over and over again for the last 3 days.
    Finally I tried putting another HDD in the caddy (500GB) and it worked like charm so I figured the 1TB drive was faulty BUT look here, I took my brother's Mid 2012 Macbook Pro 13" and put the caddy with the 1TB drive inside and it worked perfectly, fast and stable.

    Conclusion: The 1TB HDD works fine, the caddy works fine, other HDD with the caddy work fine in my MBP, the 1TB HDD doesn't work with my MBP.

    Any solution? I really need the 2nd 1TB HDD in my MBP.

    Thanks
     
  2. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #2
    2011 MBP's have known issues with SATA III drives in the optibay. My guess is your 1TB drive is of the newer SATA III variety. Try swapping positions. Place the new drive in the main drive bay and move original HD to the optibay.
     
  3. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #3
    I have the Hitachi 1TB in the main drive bay, no issues. I also have a Crucial SSD in the caddy running at full 6G Sata3 so am well chuffed.

    Swapping the drive locations would be a good first step, you may then get both drives working. If you do, check System Information to see what negotiated speed each disk is running at, if both are at 6G all good, if the caddy drive is running at 3G then you may need to move your OS/Apps to the Hitachi (in the main bay) to get your speed back.
     
  4. mbpjedi macrumors newbie

    Joined:
    May 17, 2014
    #4

Share This Page