2nd HDD Causing Problems for MBP

Discussion in 'MacBook Pro' started by matty1551, Oct 10, 2014.

  1. matty1551 macrumors 6502

    Joined:
    Jul 7, 2009
    #1
    I'm losing my mind here. I recently got a 2011 15" macbook pro. Installed a 2nd HDD in the optical slot. I took this from my old MBP where I had no issues using it. My setup was SSD in HD space. HDD in optical space.

    Anyway, I installed it in the same configuration described above and I've had nothing but problems since. If I have ANY drive installed in the optical slot, the computer is extremely slow. It boots slow, the login screen is laggy, opening disk utility results in a spinning beachball. Once I disconnect the 2nd HDD, the computer is back to normal.

    Also, I can hook any of these drives up via USB and access or format them.

    Here's what I've tried so far;

    -3 Different HDD's (Same result, verified working)
    -New optical cable (No Difference)
    -Put SSD in optical & HDD in HDD slot (No Difference)
    - NVRAM reset (No Difference)
    -Reinstalled optical drive (works fine)
    -Put HDD caddy back in 09 MBP (works fine)
    -Booted from USB to access Disk Utility (beachball)

    My next step is to purchase another HDD caddy, I just don't see how that could be the issue since it works fine in my other MBP.

    SOMEONE PLEASE HELP! SO FRUSTRATED!
     
  2. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #2
  3. matty1551 thread starter macrumors 6502

    Joined:
    Jul 7, 2009
    #3
    Thank you! With your contribution, I was at least able to get on what I believe is the right track.

    I found a another thread with the same issue regarding Sata III. This guy also had an hgst drive. He contacted support and they linked him to an application that can dictate what Sata your drive uses.

    Unfortunately this tool is windows only so I can't test it right away. I'll update tread after I try it.
     

Share This Page