2nd iPhone 5S dead within a weekend

Discussion in 'iOS 8' started by Draeconis, Apr 14, 2015.

  1. Draeconis macrumors 6502a

    Joined:
    May 6, 2008
    #1
    Hi all,

    Had previously reported iPhone 5S battery issues to a local Apple Store, they didn't replace the phone and suggested I do a DFU restore, which helped a little but not much.

    Last Friday took my phone out, which should have been on 30%, dead. Would't even ask to be charged, just completely unresponsive. Wouldn't respond to being plugged in either.

    Apple replaced it on Saturday for a brand new 5S, which just now has done exactly the same thing and stopped working. Doesn't respond, even when you plug it into charge. tried different cables and adapters, no luck.

    Both devices were running iOS 8.3 GM. Anyone seen something like this?
     
  2. TheGreenBastard macrumors 6502

    TheGreenBastard

    Joined:
    Nov 1, 2012
    Location:
    Halifax
    #2

    Just bad luck.

    Also, this should probably be in the iPhone section, not iOS 8 as it's a hardware issue.
     
  3. sanke1 macrumors 65816

    sanke1

    Joined:
    Nov 9, 2010
    #3
    Are you using a Genuine Apple charger and the cable that came with your phone? If you are using a third party charging cable, it it MFI certified?
    If yes, then get your phone replaced again. Third time lucky.

    If you are using those fake 1$ Chinese cables, get your phone replaced but don't leave the Apple store without buying a genuine charging adapter and cable.
     
  4. Draeconis thread starter macrumors 6502a

    Joined:
    May 6, 2008
    #4
    I've just realised what this is. Did a hard reset and the phone came back to life; must be a bug in 8.3 with certain set conditions.

    Very strange though, phone was obviously on otherwise it wouldn't respond to the hardware reset key presses, but the screen and backlight were off, and it didn't vibrate when connected to power.

    To answer the power questions, I only ever use Apple chargers and cables. I've no idea why people are willing to spend £600+ on a phone then skimp on the charger for it.

    I'm filing a bug report with Apple.
     
  5. Draeconis thread starter macrumors 6502a

    Joined:
    May 6, 2008
    #5
    Bug report filed, have reset my iPhone and will set it up manually rather than restore from iCloud, see if that helps.

    Phone seems to be working normally at the moment.
     
  6. MarcusCarpenter macrumors 6502a

    MarcusCarpenter

    Joined:
    Feb 18, 2013
    Location:
    London
    #6
    Restoring from iCloud could be your problem, with issues like this you should set the phone up as new
     
  7. Draeconis thread starter macrumors 6502a

    Joined:
    May 6, 2008
    #7
    Done that, phone has been fine so far.

    Apple came back to me and asked for logs from the phone, which is a shame as I've already wiped it :/
     

Share This Page