2nd iPod Classic locking up when connecting to MacBook Pro

Discussion in 'iPod' started by skiltrip, Jun 14, 2010.

  1. skiltrip macrumors 68030

    Joined:
    May 6, 2010
    Location:
    New York
    #1
    I'll sum up the lead-in story as best I can.

    I have a 2010 MacBook Pro 13". Just got an new iPod Classic a couple weeks back. I discovered that when playing the iQuiz game, I had a few lock-ups (freezing). Then a handful of times, it locked up when connecting it to the MacBook for charging or syncing. It didn't lock up EVERY time. But about 1 out of every 4 syncs on average.

    I naturally thought something was wrong with the Classic, and brought it into the Apple store when it was locked up, and they gave me a new one.

    But now this one is doing the same thing. Occasional lock-ups when connecting to the MacBook Pro. Doesn't matter which USB port. And doesn't seem to matter if the computer has been on, or if it's a fresh boot.

    What could be going on here? I doubt highly that both Classics I've gotten have the same exact issue with occasional lock-ups when connected to the computer. My MBP otherwise has given me no problems. And no problems with other USB devices, ever.

    Any ideas?
     
  2. grubworth macrumors member

    Joined:
    Jul 24, 2008
    #2
    Hey I think I seen this on the Apple Support forum?

    Anyway I have the exact same problem with my 80gb Classic, and it's because of itunes. Many Classics have this problem and nothing is being done about it. I don't think their is a thread about it here, but its a huge problem, do apple expect us to buy a new ipod? :/

    http://discussions.info.apple.com/thread.jspa?threadID=2266887&start=30&tstart=0
     
  3. skiltrip thread starter macrumors 68030

    Joined:
    May 6, 2010
    Location:
    New York
    #3
    Thanks for the link, but I don't think iTunes is the culprit in my case, but of course I can't be positive.

    But my problems happen the instant I connect the Classic to the computer. (doesn't matter which end of the cable I connect first).

    It has happened with iTunes closed, in which case iTunes never opens, and the iPod is locked up tight. It's also happened with iTunes open in which case, i Tunes doesn't recognize that I plugged anything in, and the Classic locks right up.

    Now, this doesn't happen every time. I'd say out of 2-3 syncs a day (i'm in the process of still building my library up), I'll get 1 lockup.

    Also, I've never had a problem once it's connected. My entire 60gb library has transferred without issue.

    Part of me wants to just pick up a cable to try that out in case I have a bad cable. Wish I could just get one from Apple, but I fear I'll have to prove the other one is defective in order for them to exchange it. The problem is is that it doesn't happen everytime.
     
  4. skiltrip thread starter macrumors 68030

    Joined:
    May 6, 2010
    Location:
    New York
    #4
    Well, i sucked it up and bought a new cable, but it wasn't the cable. With the new cable, the iPod locked up first try.

    So I've tried two iPods, two cables, and my USB ports have never given me any problems with any other USB devices ever (mice, drives, iLok, midi input devices), so I don't think it's my MacBook Pro hardware. That leaves software as the possible culprit. I'll continue to experiment.
     

Share This Page