2TB fusion stall issue

Discussion in 'iMac' started by littlehuman, Feb 16, 2017.

  1. littlehuman macrumors newbie

    Joined:
    Nov 22, 2010
    #1
    Hi!

    I just got my late iMac 5k with 2TB fusion a few days ago. For internet browsing and coding, it works great.

    I finally installed Lightroom and Photoshop today and I'm having delay/stall issue whenever I close either of them or change tab to tab in the application.

    When I run disk speed performance, I get 316 write and 885 read. It's actually faster than my early 2013 Macbook Pro retina.

    I'm not sure where this stall/delay comes from...

    If I'm okay with slower performance of SSD, should I change to external SSD instead?
     
  2. rbart macrumors regular

    Joined:
    Nov 3, 2013
    Location:
    France
    #2
    Do you notice a lot of disk I/O when your application stalls ?
    Maybe it's not a FD problem ...
     
  3. littlehuman thread starter macrumors newbie

    Joined:
    Nov 22, 2010
    #3
    Hi rbart,

    When I quit photoshop, CPU spikes up to 80%. Other than that..I don't see anything special.
     
  4. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #4
    How much memory do you have in your iMac and what's the memory pressure graph like? I've got a 2TB fusion in my iMac and never see any stalls like that (but I do have 32GB of Ram in it)
     
  5. rbart macrumors regular

    Joined:
    Nov 3, 2013
    Location:
    France
    #5
    If only the CPU is used, it seems it's not a FD issue
     
  6. littlehuman thread starter macrumors newbie

    Joined:
    Nov 22, 2010
    #6
    Hi Phil A., I have 24gb ram.
    --- Post Merged, Feb 17, 2017 ---
    It's tricky to debug in that case..
     
  7. varian55zx macrumors 6502a

    varian55zx

    Joined:
    May 10, 2012
    Location:
    San Francisco
    #7
    Even though you have a fusion drive if you run a disk speed test like BlackMagic it only measures the speed of the SSD portion.

    Your issue may stem from the fact that your fast SSD portion is working with a very slow HDD portion (i.e. The fusion setup).
     
  8. rbart macrumors regular

    Joined:
    Nov 3, 2013
    Location:
    France
    #8
    When the problem occurs, the OP doesn't notice any disk I/O, onlys high CPU usage, so the problem is not the FD.
     
  9. varian55zx macrumors 6502a

    varian55zx

    Joined:
    May 10, 2012
    Location:
    San Francisco
    #9
    OK I may have misread.

    Now that I go back I do see where he mentions that.

    It's possible it may have nothing to do with the drive at all.

    I don't see anything indicating it must be due to the drive or fusion drive.
     
  10. littlehuman thread starter macrumors newbie

    Joined:
    Nov 22, 2010
    #10
    So for..lightroom, it is actually a known issue. It has nothing to do with fusion drive. If you configure your lightroom to use your GPU, it stalls time to time.

    For photoshop, I still have no idea.
     
  11. nambuccaheadsau macrumors 6502a

    nambuccaheadsau

    Joined:
    Oct 19, 2007
    Location:
    Nambucca Heads Australia
    #11

Share This Page