2TB Samsung SSD Issues

Discussion in 'MacBook Pro' started by smoknmirrors, Dec 13, 2015.

  1. smoknmirrors, Dec 13, 2015
    Last edited: Dec 13, 2015

    smoknmirrors macrumors newbie

    smoknmirrors

    Joined:
    May 1, 2012
    Location:
    Titletown, USA
    #1
    I'm wondering if anyone else is having issues with 2TB 850 Pro SSDs in Mid 2012 MacBook Pros.

    I have a Mid 2012 MacBook Pro (15-inch 2.3Ghz Intel Corei7, 8GB Memory, OS X Yosemite 10.10.5)

    For over a year now I've been running it what a 512G Samsung 840 Pro boot disk and a 1TB 840 EVO in the CD bay (using an adapter tray). I want to change out the 1TB EVO for a 2TB PRO but each time I image the 1TB to the 2TB my machine starts acting weird. Writes don't happen, the system hangs or just generally works poorly.

    I put the 1TB back in and the system picked right up and worked without issues. A friend suggested it could be a permissions issue or something, so I imaged it again. Same results. I then used TechTool Pro 8 to make the image. Also same results.

    Here's the part that is just blowing my mind... If I take the non-working 2TB disk having just imaged it and attach it using a SATA-USB adapter, it works fine. The system runs well and the performance is pretty good. Obviously I can't run around with my second drive hanging six inches off my USB port.

    The only idea I have is that there is some sort of firmware issue with running a >1TB on the internal SATA port meant for the CD drive, but honestly, I don't know why it wouldn't work.

    Is anyone aware of any issues like this or have suggestions on what to try?
     
  2. MadDane macrumors 6502a

    Joined:
    Apr 5, 2015
    #2
    Have you tried using the 2TB SSD without putting the image from the 1TB on it? That way you could see whether it is the image that is causing the problem or not. Alternatively you could switch the 512GB and 2TB drive around and see if that works.

    Just curious. How come you are switching the 1TB and not the 512GB drive with the 2TB?
     
  3. smoknmirrors thread starter macrumors newbie

    smoknmirrors

    Joined:
    May 1, 2012
    Location:
    Titletown, USA
    #3
    Thank you for the reply. I have not tried a fresh build on the 2TB. The second disk has everything of substantial size including my download directory and all my virtual machines. I'm desperate to NOT rebuild the machine. Frankly, I don't even have time to be doing this level of troubleshooting. It's wasted several hours of effort and at least four days of real time imaging and reimagine. I don't suspect the copy itself because the drive operates perfectly when run through the USB. If there was a problem with the image the permissions, I'd expect it to fail regardless.

    As for why I'm changing the drives, the original plan was to move the 1TB down to boot disk, bumping me from 1.5 to 3 total. I probably could get away with just the 2TB for right now, but I don't want to rebuild everything and I need the space for all my junk.
     
  4. MadDane macrumors 6502a

    Joined:
    Apr 5, 2015
    #4
    I don't have any experience with the 2TB drive, only 1TB. But here is what I would try.

    Format the 2TB SSD. If it is performing with no issues I would simply copy the entire drive from the 1TB to 2TB (no cloning). If I understand you correctly, it is simply data on the 1TB drive and therefore it should be possible to use good old copy/paste. After they copying of data has finished, see how it performs.

    If the drive is performing poorly, even right after it is formatted with no data on it, then the problem must be either the caddy or the connection (or something related to that). In that case I would switch the 512GB and 2TB around and see if that will work. Since both the drives are using SATA connections, it shouldn't matter where each drive is placed physically in the machine.
     
  5. Mr. Retrofire macrumors 601

    Mr. Retrofire

    Joined:
    Mar 2, 2010
    Location:
    www.emiliana.cl/en
    #5
    @smoknmirrors:
    It is possible that the 2 TB Pro firmware enforces SATA 6 GBit/s and your SATA cable is not compatible. Make sure you install newest firmware update(s) on your MBP.
     
  6. smoknmirrors thread starter macrumors newbie

    smoknmirrors

    Joined:
    May 1, 2012
    Location:
    Titletown, USA
    #6
    Thanks. This is more along the lines of what I suspect. I'll give it a try.
     
  7. MrAverigeUser, Dec 18, 2015
    Last edited: Dec 18, 2015

    MrAverigeUser macrumors 6502a

    MrAverigeUser

    Joined:
    May 20, 2015
    Location:
    europe
    #7
    Since the OP has a 15" MBP, I doubt a little bit this will resolve the problem…

    "When the 2012 MacBook Pros were released, we found that SATA 3.0 SSDs—such as the OWC Mercury EXTREME Pro 6G and the Mercury Electra 6G—exhibited poor performance and reliability in the 13-inch model when installed in the optical bay via an OWC Data Doubler, while the same SSDs in the 15-inch model worked just fine."

    Exchanging the positions of the 2 SSD would perhaps help to exclude a possible problem with the SATA-connections…
    As both SATA-Connections are SATA III this would change nothing at all...
    As I want to upgrade my original 512 GB SSD in the same machine by installing the Samsung 850 2TB EVO at its place and installing a 840 1TB in the optical bay, I am very interested to know if this exchange (2TB in the main SATA-Position) would perhaps resolve the problem…

    perhaps is simply like that: The system does not accept more than 1 TB in the optical bay?
    If Yes: Exchange of the 2 SSD would resolve the problem…

    have also a look here:

    http://forums.macrumors.com/threads/ssd-buying-guide-2015.1898945/page-17#post-22355902

    perhaps this User could help you with his experiences...
     

Share This Page