3.0.1 3GS user running iTunes 9...what are my options?

Discussion in 'Jailbreaks and iOS Hacks' started by daneoni, Sep 16, 2009.

  1. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #1
    I haven't been following the JB circuit since i had a 4GB 2G iPhone imported from the US and have been pretty much legit since upgrading to the 3G and later on 3GS

    I currently have a launch week iPhone 3GS running 3.0.1/04.26.08 with iTunes 9. Never jailbroken/unlocked and i also have my iBec files tucked away. I just realised that Apple has gone on the offensive preventing me from restoring to even a 3.0.1 and will only allow me go up to 3.1 which, i haven't done

    Now i'd like to keep the option of unlocking the phone purely for resell value as i'm in fact mostly happy with O2 and don't really need to JB. Any ideas what i need to do to accomplish this?
     
  2. ozzyman500 macrumors 65816

    Joined:
    Feb 4, 2009
    #2
    If you have the 3.0 firmware use redsn0w and when you jailbreak browse to the 3.0 software. Then follow the steps.
     
  3. daneoni thread starter macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #3
    I don't understand are you telling me to find the 3.0 firmware online and use redsnow? wouldn't the phone need to be running 3.0 firmware (which its not) and how would i go about downgrading to that (currently 3.0.1)

    Also does anyone know how to get to /etc/hosts detailed in Saurik's post on a Mac?
     
  4. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #4
    What he's saying is that redsn0w can't jailbreak 3.0.1 directly but it can use the same injection method as 3.0 to jailbreak a 3.0.1 device. You use redsn0w as shown on sites like iClarified, etc but when prompted for the ipsw, instead of pointing to a 3.0.1 ipsw, point it to a 3.0 ipsw and you should be good to go. :)

    Command-Shift-G
     
  5. daneoni thread starter macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #5
    Thanks

    Weird it says folder can't be found
     
  6. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #6
    After Command-Shift-G, you typed /etc and not /etc/hosts correct? /etc/hosts is a file not a folder so that might be your issue. :)
     
  7. angemon89 macrumors 68000

    angemon89

    Joined:
    Feb 5, 2008
    Location:
    The place where Apple designs stuff
    #7
    I'm in the same boat. I want to update to 3.1 but don't want to lock out my phone (possibly forever?) for future resell.

    Am I correct that if I wait for the 3GS 3.1 PwnageTool and update to 3.1 without upgrading my baseband, that I will preserve my phone's unlockability?
     
  8. daneoni thread starter macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #8
    Thats the gist until the Dev team can unlock the current baseband if ever but Pwange tool doesn't support the 3GS at the moment

    Yeah i figured and have done it now thanks. However i tried to test it out by restoring to 3.0.1 (currently running 3.0.1) and got this as opposed to the start build compatibility error

    *Shrug* i know i'm doing something noobish
     

    Attached Files:

  9. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #9
  10. daneoni thread starter macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #10

Share This Page