3.0 keeps asking me about joining wifi...

Discussion in 'iPhone' started by pendo, Jun 27, 2009.

  1. pendo macrumors regular

    Joined:
    Aug 14, 2008
    Location:
    Jenks, OK
    #1
    I don't recall seeing any posts about this...

    Ever since I upgraded to 3.0, I keep getting the pop up to select a wifi network. My phone has always automatically joined with our router here at home, but for some reason it always asks me to select a wifi network.

    It does remember the password, so all I have to do is select our router, but this is annoying. It never used to do this before.

    I upgraded to 3.0 via Pwnage Tool, and have also installed the ipcc file when trying to enable mms. But it did this even before I did this.

    Any ideas?
     
  2. amlweems macrumors newbie

    Joined:
    Aug 16, 2007
    #2
    Just turn off the Ask to Join Networks setting.
     
  3. rburly macrumors 6502a

    rburly

    Joined:
    Jan 15, 2009
    Location:
    Florida
    #3
    If you don't use it, or want to use it (I don't): Settings-> Wifi-> Off.

    You can enable or disable as you want. If you don't it'll keep asking.
     
  4. pendo thread starter macrumors regular

    Joined:
    Aug 14, 2008
    Location:
    Jenks, OK
    #4
    but turning of the 'ask to join network' button still doesn't fix my problem.

    Right under that button it says: Known networks will be joined automatically.

    My home network should be a known network. It always automatically joined before.
     
  5. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #5
    I don't think either of the previous posters really helped you. I've noticed that it's done that a few times to me in my house since OS 3.0, but it was only once or twice that it did, and hasn't since done it, so i don't know what to tell you.
     
  6. english06 macrumors member

    Joined:
    Apr 15, 2009
    #6
    Go settings>wi-fi and hit that blue arrow next to your home wifi.

    Make sure "Auto-Join" is ON
     
  7. pendo thread starter macrumors regular

    Joined:
    Aug 14, 2008
    Location:
    Jenks, OK
    #7
    I don't have this option in the settings menu.
     
  8. doubleatheman macrumors 6502a

    doubleatheman

    Joined:
    May 27, 2009
    #8
    My phone is also asking me to enter passwords into random routers as I'm walking downtown, and I have the ask to join netoworks option off.

    Slightly annoying, I just turn wifi off if I have the problem.
     
  9. SeanC1966 macrumors newbie

    Joined:
    Jun 28, 2009
    #9
    I had this problem after upgrading to 3.0. I cured it by telling iPhone to forget my home network and then setting it up again from scratch. Had no problems since.
     
  10. pendo thread starter macrumors regular

    Joined:
    Aug 14, 2008
    Location:
    Jenks, OK
    #10
    THANK YOU!!

    This seems to have worked. Awesome;)
     
  11. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #11
    Sounds like good advice. I'll have to remember this if it gets too annoying, but right now it's too sporadic.
     

Share This Page