3.1.2 iPhone 3GS Blackra1n jailbreak no longer working

Discussion in 'Jailbreaks and iOS Hacks' started by stumpinho, Jul 15, 2010.

  1. stumpinho macrumors newbie

    Joined:
    Jul 14, 2010
    #1
    Hi guys.

    Im new to these forums so bare with me while i try to explain my problem. I created a new thread because i dont think anyone has done something as stupid as i have :eek:... although if there is one you can redirect me to with a problem exactly like this then do that by all means
    .

    I've been running an iphone 3GS with firmware 3.1.2. jailbroken with blackrain and unlocked for quite a while now and its been working great.

    Although recently i jailbroke my friends ipod touch with spirit, and seeing how easy this was i decided to give it a go with my phone (i backed up before hand so if things turned sour i could just restore and reload my data).

    After i tried this spirit jailbreak, the phone entered recovery mode so it obviously didnt work. But the problem now is that when i try to restore it via itunes to 3.1.2. i get an error message which is something along the lines of "The iPhone could not be restored because the device isnt eligible for the requested build".

    So seeing as i couldnt restore it to factory settings this way, i tried re-jailbreaking it using blackra1n which i have used before as mentioned. However when i do this now it seems to look like its working (the guys face comes up) but when it reboots it just slips back into recovery mode and blackrain automatically tries to jailbreak it again. This cycle repeats itself indefinately.

    So basically my iphone is in limbo as i can no longer restore it to factory settings due to the firmware error and i cant jailbreak it because blackrain is no longer doing it for me (ive tried re-downloading blackrain, and doing it on a different pc to no avail).

    Any ideas? I was thinking that by using spirit my firmware has been altered somehow but im not sure.

    Any suggestions are most welcome!

    Cheers
     
  2. CJayC macrumors 6502

    Joined:
    Jun 2, 2010
    #2
    Can you be more concise? Tell me the problem in less words.
     
  3. pixelated macrumors 6502a

    pixelated

    Joined:
    Oct 21, 2008
    #3
    You tired Spirit on your already JB phone?
    If you have SHSH blobs saved for any FW's you can restore to those specific versions by editing your hosts file.
    If you didn't restore before hand and have the old bootrom, you may be able to restore to a custom FW, which bypasses the signature check.
     
  4. stumpinho thread starter macrumors newbie

    Joined:
    Jul 14, 2010
    #4
    Basically my already jailbroken (with blackra1n) iphone 3GS, on 3.1.2, is useless as i cant get it out of recovery mode. Itunes wont let me restore it either.

    Yes i did try spirit :(

    Ive never done anything to do with SHSH blobs so im guessing i dont have any saved.

    Maybe the custom FW thing is worth a try? Would you mind directing me to somewhere where i can do this/show me how its done?
     
  5. stumpinho thread starter macrumors newbie

    Joined:
    Jul 14, 2010
    #5
    UPDATE:

    I downloaded custom firmware for 3.1.2 and put it together using HJSplit although when trying to restore using this through itunes instead i get a 1600 error. Ive tried googling it but i cant find a solution which works for me!

    gahhhhhhhhhhhhhh
     
  6. pixelated macrumors 6502a

    pixelated

    Joined:
    Oct 21, 2008
    #6
    Is this because you were operating on a tethered JB through blackra1n?
     
  7. stumpinho thread starter macrumors newbie

    Joined:
    Jul 14, 2010
    #7
    Loosely yes - i wanted to remove the tether and unwittingly used spirit beacuse it seemed so simple after i jailbroke my friends ipod touch. :(

    I just tried redsn0w again and although promising, once it goes through the sequence of jailbreaking the phone just enters recovery mode once more. Currently it is in nothing mode. Screen is blank, cant even get it into recovery...
     
  8. brian540 macrumors member

    Joined:
    Jun 21, 2010
    #8
    if you dont have your blobs you will be forced to upgrade to 4.0

    one thing you can try is use tinyumbrella http://thefirmwareumbrella.blogspot.com/

    see if you can get your blobs and you may also be able to kick your self out of recovery mode

    and press kick device out of recovery


    or manually

    Using rslite, you'd do:
    % rslite
    rslite v0.2 - by the iPhone Dev Team, 2009.
    --THIS IS AN UNSUPPORTED TOOL--

    Connecting...
    [Recovery] setenv auto-boot true
    [Recovery] saveenv
    [Recovery] reboot

    otherwise restore to 4.0 and either A. if your on old bootrom pwnage tool or if your on new wait patiently
     
  9. stumpinho thread starter macrumors newbie

    Joined:
    Jul 14, 2010
    #9
    Cheers.

    Im giving the umbrella thing a go now, except i cant even get it to detect my phone... im holding power and home buttons and i hear the usb connecting/disconnecting but nothing on the phone and tinyumbrella isnt detecting it... fark.
     
  10. brian540 macrumors member

    Joined:
    Jun 21, 2010
    #10
    download http://iphwn.org/rslite102semi.zip rslite from there...

    you can try and see if it works otherwise you may be stuck going to 4.0 if you don't have any blobs saved? Did you check the thing in cydia to save them? and did it say at the top saved blah blah?
     
  11. stumpinho thread starter macrumors newbie

    Joined:
    Jul 14, 2010
    #11
    I dont think i have blobs saved - ive just tried to go to 4.0 but when trying to do it through itunes ive now got error 1601 once more. At least the phone is showing signs of life it has a fully grey screen now.

    Any ideas?
     
  12. brian540 macrumors member

    Joined:
    Jun 21, 2010

Share This Page