3.1 and ActivateMMS2G

Discussion in 'Jailbreaks and iOS Hacks' started by flashgj, Sep 15, 2009.

  1. flashgj macrumors newbie

    Joined:
    Mar 13, 2008
    #1
    Has anyone with a 2G updated to firmware 3.1 and got AcivateMMS2G successfully installed? I tried once and my phone got stuck at the apple logo and I had to do a restore, now I am afraid to try again.

    I have searched all over and cannot find any official word on if it works with 3.1 or not. Any success stories?
     
  2. CorranQ macrumors newbie

    CorranQ

    Joined:
    Apr 5, 2007
    Location:
    México, D.F, México
    #2
    I've had the same problem as you with this, as well as with Winterboard, though ActivateMMS is by far the worst right now, lol, have restored twice. I guess we'll just need to wait for everything to be updated for 3.1
     
  3. Ewan Hoozarmy macrumors regular

    Ewan Hoozarmy

    Joined:
    Feb 2, 2007
    Location:
    Cambridge, UK
    #3
    Exactly the same for me too, I've had to restore again. I'm leaving well alone until an update is released.....
     
  4. Melodic macrumors member

    Joined:
    Sep 5, 2008
    Location:
    NYC
    #4
    thanks for the heads up I was about to try this on my 2g but I guess I'll wait
     
  5. kory108 macrumors newbie

    kory108

    Joined:
    Nov 17, 2008
    Location:
    Appleton, WI
    #5
    Same

    I had the same issue as well, had to restore twice. Winterboard is now working though with the new MobileSubstrate 0.9.3043-1
     
  6. tlvsnjunkie macrumors newbie

    Joined:
    Sep 16, 2009
    #6
    Whew

    I'm glad to know I'm not the only person having this issue. Hopefully an update comes out soon. SwirlyMMS doesn't work so well for me.
     
  7. bigrobb macrumors 6502a

    Joined:
    Mar 11, 2008
    Location:
    Tennessee
    #7
    same thing happened to me it happened first with apt backup then I finally got it restored and i tried to download activatemms2g it just kept rebooting over and over again so I restored again I am not gonna try it again until there is an update
     
  8. gr.mon macrumors newbie

    Joined:
    Sep 17, 2009
  9. djoz187 macrumors newbie

    Joined:
    Jun 9, 2008
    #9
    Same here...

    Wish I had read this thread before I tried it...Now its 3am and I am restoring my phone! This thread needs to be bumped once there is an update!!!
     
  10. kdawg macrumors regular

    kdawg

    Joined:
    Dec 14, 2004
    #10
    +1

    Read somewhere that some people did have luck with it though... Don't know who yet... maybe it will activate when ATT/Apple give the go ahead... 3.1 Runs much better on my phone than 3.0... but I do miss MMS. Small price to pay.
     
  11. spaceballl macrumors 68030

    spaceballl

    Joined:
    Nov 2, 2003
    Location:
    San Francisco, CA
    #11
    Interesting thread - will be monitoring this!
     
  12. bjnyc macrumors newbie

    bjnyc

    Joined:
    Oct 4, 2009
    Location:
    NYC
    #12
    As of September 25th, it seems mms for iphone 2G is not allowed on AT&T. Activatemms2g sets it up but the network will not allow it to send/receive. It may have to do with the IMEI# and SIM.:mad:
     
  13. Vegastouch macrumors 603

    Vegastouch

    Joined:
    Jul 12, 2008
    Location:
    Las Vegas, NV
    #13
    Havent tried it. Still waiting for a windows JB version.
     
  14. Ewan Hoozarmy macrumors regular

    Ewan Hoozarmy

    Joined:
    Feb 2, 2007
    Location:
    Cambridge, UK
    #14
    Looks like a fix may be on the way -

    iPhone 2G - 3.1.2 MMS - DEVS ONLY

    and hopefully released to Cydia soon, for those of us that aren't technically skilled enough to manually apply these mods :rolleyes:
     
  15. nickels macrumors member

    Joined:
    Oct 3, 2008
    #15
    Until a USA AT&T user confirms this works I'll sit back and wait. So far all I can see is that T-mobile users are having some luck.
     
  16. Vegastouch macrumors 603

    Vegastouch

    Joined:
    Jul 12, 2008
    Location:
    Las Vegas, NV
    #16
    Gotta say, ......i was using Ativatemms2g from cydia but i also have SwirlyMMS. Well since Activatemms2G isnt available anymore, i just went back to SwirlyMMS and i dont know if it is the upgrade to 3.1.2 or what, but my battery life is emmensly better than it was on 3.0.1.

    I have had my phone on since 5:45 am this morning and it is still at 77% right now at 5:15 pm. Usually by now it is in the 40's.
     
  17. hungboii macrumors newbie

    Joined:
    Oct 20, 2009
    #17
    hey all, i am very new here, i have had an iphone for a few years and when i updated to 3.0 when it first came out, i got the activatemms2g and it worked wonders. i sold my 8gb 2g and upgraded to a 16gb 2g and, like most people here, can no longer fing the program. i was feeling a litle down until i went searchng last night and found another source with the mms feature!!!!! i added: repo.sinfuliphone.com and installed the "enable mms for 2g &3.0," crossed my fingers, and it worked great. hope this helps you guys as much as it did me :)

    ps: i read that if you previously habe any configurations for mms, and try to add this, it will cause you to restore your phone. so before you install this, make sure its the ONLY mms program on your phone. (it happened to my cousin, he had to restore his phone and now its working great)
     
  18. hungboii macrumors newbie

    Joined:
    Oct 20, 2009
  19. Vegastouch macrumors 603

    Vegastouch

    Joined:
    Jul 12, 2008
    Location:
    Las Vegas, NV
    #19
    Said source cant be found when i typed it in. You sure that is the source? Maybe missing something in the link?
     
  20. hungboii macrumors newbie

    Joined:
    Oct 20, 2009
    #20
  21. Vegastouch macrumors 603

    Vegastouch

    Joined:
    Jul 12, 2008
    Location:
    Las Vegas, NV
    #21
    There we go. Ill check it out but i have put SwirlyMMS back on and not sure if that is the reason but im getting crazy good battery life now when i upgraded to 3.1.2 without the regulat MMS hack.
     
  22. Vegastouch macrumors 603

    Vegastouch

    Joined:
    Jul 12, 2008
    Location:
    Las Vegas, NV
    #22
    Just installed and got my camera icon. Havent tested sending a picture yet. Will do tomorrow and ill also see if my battery life will still be good.

    Cool, i have 3.1.2 and it installed fine anyways.
     
  23. trajen macrumors 6502a

    Joined:
    Oct 2, 2008
    #23
    The repo doesn't have the activatemms2g package. Is it even compatible with 3.1.2? I've seen posts about a reboot screen loop/hang.
     
  24. ignus graius macrumors regular

    Joined:
    Dec 4, 2005
    #24
    If you're on a 2G and have upgraded to 3.1 or beyond, you're not going to be able to use native MMS unless you patch CommCenter (see Ewan Hoozarmy's earlier post). Unless CommCenter has been patched, carrier modifications like ActivateMMS2G won't work.

    I could be wrong, but I think worst-case scenario of an unsuccessful attempt at patching CommCenter would be having to a restore. I just patched a 3.1.2 CommCenter on a 3GS to enable tethering and it wasn't a big deal for people who are familiar with the file structure.
     
  25. trajen macrumors 6502a

    Joined:
    Oct 2, 2008
    #25
    I tried installing activatemms2g from a different source and ending up having to restore. I'm pretty good at SSH but I'm not going to try the CommCenter hack by a long shot. Hell-to-tha-no.
     

Share This Page