3 big problems between my gmail and iphone 4 inbox...

Discussion in 'iPhone' started by epbdo, Jul 23, 2010.

  1. epbdo macrumors newbie

    Joined:
    Jun 20, 2010
    #1
    I know these are not new issues, but I just haven't found a solution yet. I've had 3 main issues with my gmail and iphone 4 inbox:

    1) I've had ongoing issues of these weird email messages from 1969, and also from 2000 with no subject, sender, and can not be deleted. I've done everything mentioned on every forum available from hard reset of the phone to switching everything imaginable on or off related to contacts, mail, threads, etc., deleting and resetting the account on my phone and computer, going to gmail help pages and adjusting imap, you name it, I've done it. They all seem to correct the problem temporarily, but then eventually at some point, these emails return and disappear by themselves at some point with no rhyme or reason and there's nothing I can do about them when they're present. I've called Apple several times and they always say the same exact thing about hard resetting, but it's never a long lasting solution.

    2) After I delete multiple messages from my inbox, they often reappear as unread messages and I have to open and delete each one again which is really annoying.

    3) Often I open an email and click on delete. The garbage can lid opens and the screen freezes. I have to hit home to get out. When I go back to the inbox, it's white with nothing present. I have to go back and forth between apps and the inbox and eventually the inbox emails will reappear.

    If anyone has any new solutions to any of these problems, please share the wealth because I'm tempted to stay with my Verizon blackberry and cancel this iphone/ATT account since I've never dealt with any of these persistent problems with other phones. If iphone really does go to Verizon soon as the rumors say with all these issues (including antenna) fixed by that time, I'll be really disappointed that I stuck it out with this phone with a contract for 2 years.

    Thanks!
     
  2. iammike1 macrumors 6502a

    iammike1

    Joined:
    Oct 25, 2007
    Location:
    Columbia MD
    #2
    Try this...

    Open the app switcher by double tapping the home button.
    Press and hold on any icon.
    Tap the red X on the Mail app.
    Press home to close the app switcher.
    Open Mail.

    I had mine go wonky on me once and that straitened it out. Lots of changes in the Mail app for 4.0 so I have no doubt new bugs have been introduced. Probably straiten some of them out in 4.1.
     
  3. epbdo thread starter macrumors newbie

    Joined:
    Jun 20, 2010
    #3
    Thanks Mike, I tried it...I'm crossing my fingers! By the way, what exactly does that do?
     
  4. EstrlM3 macrumors 6502

    Joined:
    Apr 16, 2010
  5. JayLenochiniMac macrumors G5

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
    #5
    Is your delete button set to "delete" or "archive"?

    Have you tried setting up Gmail via Micosoft Exchange? Make a separate account using this (you can turn off calendar and contacts syncing) and see if it solves the problem. If so, you can delete the other account.
     
  6. kginm1 macrumors newbie

    Joined:
    Jul 31, 2010
    #6
    the delete/ archive button change just fixed this problem. The strange emails disappeared instantly. Thanks for that! I have been waiting for a solution for awhile.
     
  7. epbdo thread starter macrumors newbie

    Joined:
    Jun 20, 2010
    #7
    Thanks for the help. However, I'm not sure how to tell if it's set to delete or archive. How do I get there and what should t be set as (assuming delete)? I think I initially set up my gmail through Microsoft exchange, but not sure if I did it separately also by accident when I deleted and reentered the gmail account trying to solve the problem unsuccessfully.
     
  8. falconman515 macrumors 6502a

    falconman515

    Joined:
    Jun 8, 2010
    #8
    Go to your settings and then mail click on your gmail account and you have an option of delete or archive... set to delete and your good.
     

Share This Page