3 finger "look-up" gesture bug in 10.10.3

Discussion in 'OS X Yosemite (10.10)' started by Doctoreggman, Mar 15, 2015.

  1. Doctoreggman, Mar 15, 2015
    Last edited: Mar 15, 2015

    Doctoreggman macrumors newbie

    Joined:
    Jun 23, 2014
    #1
    Enabled a new feature which included google search when using the 3 finger tap gesture for dictionary definitions ... the pop-up box appears and no freezes with no definitions and then the keyboard doesn't register inputs after this (even when the look-up overlay is dismissed).

    Anyone else found this to occur? Is there a way to return "look up" to just dictionary/wikipedia again?

    Thanks

    EDIT: Found under system settings the ability to include spotlight search in look-up but still doesn't help at the moment
     
  2. SmOgER macrumors 6502a

    Joined:
    Jun 2, 2014
    #2
    I can't see nowhere in the settings neither ability to enable google search nor the spotlight in the look up.
     
  3. Watabou macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
    #3
    Yep, I had this occur multiple times yesterday, very frustrating. The popup seems to be blank too for me. I tried enabling and disabling the checkboxes for look up and dictionary definitions, and rebuilding the Spotlight indexes and these didn't seem to help.

    I submitted this as a serious bug to bugreport.apple.com, I highly suggest you do the same. (Please don't ignore this, even if your bug gets flagged as duplicate, the way the system works is -- the more duplicates, the higher the bug priority)
     
  4. hojoon0724 macrumors regular

    Joined:
    Jun 26, 2007
    Location:
    Los Angeles, CA
  5. zxjcarrot macrumors newbie

    Joined:
    Mar 17, 2015
  6. Watabou macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
    #6
  7. Ramychan macrumors newbie

    Joined:
    Sep 17, 2012
    Location:
    Palm Harbor, Florida, USA
    #7
    Same problem here, too. Extremely frustrating!
     
  8. Watabou macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
    #9
    I posted the workaround two posts above.
     
  9. Doctoreggman thread starter macrumors newbie

    Joined:
    Jun 23, 2014
    #10
    Thanks for that buddy, will report it also.
     
  10. Sylon macrumors 68020

    Sylon

    Joined:
    Feb 26, 2012
    Location:
    Michigan/Ohio, USA
    #11
    At least I'm not the only one. Man this has been pissing me off. I had to turn that gesture off for the time being.
     
  11. antons macrumors newbie

    Joined:
    Apr 10, 2015
    #12
    Hi guys. I managed to get it back to normal with utility named BetterTouchTool.

    In trackpad settings - disable the lookup gesture.

    In BetterTouchTool - go to Preferences -> Trackpads -> Global and bind three finger tap to action which begins with "lookup".

    Screenshot from BTT settings:
    [​IMG]
     

Share This Page