3+ Multiple Displays not working with 10.9.3

Discussion in 'OS X Mavericks (10.9)' started by macpro2000, May 15, 2014.

  1. macpro2000 macrumors 6502a

    Joined:
    Apr 20, 2005
    #1
    I had this problem with the betas but figured it would be taken care of in the public release, but no go. I have a new Mac Pro with 4x30" ACDs and all work perfectly in 10.9.2. However when updating to 10.9.3, it only allows 2 displays to be displayed, and only 2 show up in system preferences. What a pain. I restored from Time Machine back to 10.9.2 and all is well. Kinda stinks that I can't be updated though. Any ideas?
     
  2. bxs macrumors 6502

    Joined:
    Oct 20, 2007
    #2
    What if you connect displays to different TB ports. Given you have 4 displays you will obviously have to have 2 displays on one TB bus. Worth a try maybe.
     
  3. barneyboo macrumors newbie

    Joined:
    Aug 31, 2012
    #3
    I'm having all sorts of display issues with my 2012 rMBP since 10.9.3
    I can have one monitor connected by DisplayPort without any issues, but the second, while recognised, only shows a black screen. I can get a cursor on that second display, but can't drag apps to it or anything. My third display connected by HDMI doesn't work at all in any configuration.

    Really poor :/

    Oh, and this is happening to my menu bar...
    [​IMG]
     
  4. macpro2000 thread starter macrumors 6502a

    Joined:
    Apr 20, 2005
    #4
    Tried it and no diff, which also doesn't make sense with the bus deal if it worked fine in 10.9.2. I also spoke with a senior apple engineer directly and was told that the nMP would support 6 30" ACDs. I was assured it would be fixed promptly.
     
  5. gatd macrumors member

    Joined:
    Jun 2, 2008
    #5
    I got it working by deleting Geforce and NVD Kexts and installing the ones from 10.9
     

Share This Page