30" Cinema Display DEAD ?

Discussion in 'Mac Pro' started by psymas, Nov 30, 2010.

  1. psymas macrumors newbie

    psymas

    Joined:
    Jul 29, 2008
    Location:
    Denmark
    #1
    This morning I found my 30" apple display completely "dead" :(

    My system:

    Mac OS X 10.6.5 completely updated
    2 x 2.66 GHz Dual-Core Intel Xeon
    4 GB 667 MHz DDR2 FB-DIMM
    ATI Radeon X1900 512 MB RAM

    Dual monitor setup
    Monitor 1= Cinema display 30"
    Monitor 2= Eizo CG222W (working fine)

    I have tried the following with no luck:

    I swapped the monitor cables between the two DVI ports, thought the DVI connector for the Cinema Display was dead

    I removed the Eizo monitor to a stand alone setup with only the Cinema Display going. I tried both DVI ports.

    Finally I moved my Cinema Display to my second mac pro workstation and fortunately the display worked perfectly with another mac :)

    Now I'm running my workstation with my Eizo CG222W. When I enter my display configuration then the Cinema Display is still registered but not working ?

    By the way, the button on the Cinema Display was configured to turn on and off the display.

    I have been looking through the different threads in this forum and did not find any others with this kind of problem, unfortunately.

    I hope some one might be able to come up with a good guess about this some what strange problem.

    Best regards,

    THOMAS
     
  2. peskaa macrumors 68020

    peskaa

    Joined:
    Mar 13, 2008
    Location:
    London, UK
    #2
    Sounds like your graphics card is shot, with a problem driving dual-link DVI. Your Eizo is single link, so it works fine, and the other Mac you tried proves that the 30" ACD is working fine.
     
  3. psymas thread starter macrumors newbie

    psymas

    Joined:
    Jul 29, 2008
    Location:
    Denmark
    #3
    NOW working :)))

    I have no idea about the solution but after fiddling around with the power supply and the USB and the Firewire cables to the screen the screen came to life :) I read that some displays did not start because of a dead USb hub and therefore I thought I better check it out. My USB hub works fine so do the firewire, so I have no idea about why it did not work like 2 hours ago..maybe it's because I turned the cable to the PSU the wrong direction (it seems to fit both ways)...But after all I'm happy that I have my loved 30" back to life :D
     

Share This Page