300% kernel_task CPU usage on Macbook Air 6,2

Discussion in 'MacBook Air' started by andr3wmac, Dec 19, 2014.

  1. andr3wmac macrumors newbie

    Joined:
    Dec 19, 2014
    #1
    Hey everyone,

    Unfortunately there was a liquid spill on my 2013 MacBook Air. I shut it off, disassembled it and cleaned it out and dried it. I reassembled it and tested each of the hardware features (camera, speakers, mic, usb, etc) and to my surprise everything works fine.

    It wasn't until after I used it for a few hours that I noticed it was shockingly slow. I investigated it and found kernel_task to be eating 300% CPU. After a little googling I was lead to threads on here and other mac forums with people who have had similar issues. Apparently the computer believes it's hot and is eating up CPU with low cost tasks in an attempt to throttle applications it believes are heating up the computer. I installed HWMonitor, and sure enough Heatpipe 2 sensor is showing 128 Degrees Celsius. Also, the Apple Diagnostics reports PFM006 which I believe is the SMC.

    I've looked over the board again and gave it an extra hard look for corrosion and I can't spot anything I can clean further. If I can't fix it on a hardware level I'd be satisfied with a software level solution. It just seems a shame to discard this expensive computer because of CPU usage. The problem seems solvable.

    I found this which sounds great:
    http://www.rdoxenham.com/?p=259

    As well as many other people who used the fix successfully. I'm running Mac OS X 10.9.5 and it's a MacBookAir6,2. Unfortunately under /System/Library/Extensions/IOPlatformPluginFamily.kext/Contents/PlugIns/ACPI_SMC_PlatformPlugin.kext/Contents/Resources there is no MacBookAir6_2.plist. I decided to move all the files out of there but it didn't help.

    I also found this:
    http://tech.superhappykittymeow.com/?p=258

    But unfortunately I don't have either of those available when I look. Can anyone shed some light on why I can't apply these fixes? Has something changed in the macbook air 6,2 model that prevents these fixes from working? Or is it because I'm using OS X 10.9.5 ?
     
  2. martinm0 macrumors 6502a

    Joined:
    Feb 27, 2010
    #2

    What's the health of the battery? I acquired a 2011 MBP from a friend of mine. It had been sitting unused for the last few years and the battery was totally dead. It would still run, but the CPU was fully taxed and I tracked it to the same kernel_task you listed above. As others had mentioned, I went and removed the files from the plist (I think the same you have listed above, but I'm too lazy to review it now...). That made the machine run, but it seemed to remove all the acceleration features as Geekbench was giving me a fraction of what the score should be.

    I finally went and bought a new 3rd party battery from Amazon and it seems to have fixed all my issues. I did a fresh install and ran some benchmarks, all of which came out normal now.

    Not to say there isn't something else wrong after the spill, but if it impacted the battery, I can see that possibly being the issue here.

    Good luck!
     
  3. andr3wmac thread starter macrumors newbie

    Joined:
    Dec 19, 2014
    #3
    Thanks for the reply!

    Battery is working fine. It can fully charge and still has all the life it did before. Your suggestion did make me curious though, so I booted the computer with the battery unplugged. Unfortunately I'm still seeing 300% usage on kernel_task.
     
  4. cyber16 macrumors 6502

    Joined:
    Jan 12, 2013
    #4
    Disconnect the trackpad at the logic-board, one small ribbon cable .
    Then test again with-out the trackpad, YOU will also need to use an external usb keyboard for this test.
    If the system runs faster as normal.
    You will need to remove the trackpad and clean the connections on the pcb on the underside or replace the trackpad

    That pcb on the underside of the trackpad seem to always get burned out since liquid can pass by the edges of the trackpad

    my $0.02
     
  5. m4doyle macrumors newbie

    Joined:
    Feb 9, 2015
    #5
    i am in the IDENTICAL situation. liquid damage, was working fine, now a month later after a liquid cleaning this is going on. I am 6_2 as well. clean installed yosemeti, nothing.
     
  6. andr3wmac thread starter macrumors newbie

    Joined:
    Dec 19, 2014
    #6
    Bump. I never did solve this. I'm taking another stab at it though. Anyone have any new ideas? If I could just get around that one sensor the computer would function fine.
     
  7. randy2k macrumors newbie

    Joined:
    Oct 19, 2016
    #7
    Did this ever get resolved? I have an early 2014 with that same problem. The PLIST process will not work of course. The storage overheats due to the kernel_task pegging it at 400%, fans stays on, etc.

    Yes it could be, and must be, a sensor that is failing. Looked at replacing sensors and it appears that is not available. I could do it but need information. Don't want to replace the motherboard.

    Things done -
    1. purchased and installed iStat menu to locate source of overheating - turned out to be SSD.
    2. swapped SSD with other Macbook Air. Works fine no overheating. eliminates the SSD card. Then put in good known SSD from other system and worked fine but storage starts to overheat.
    3. moved the /System/Library/Extensions/IOPlatformPluginFamily.kext/ ~ to no avail.
    4. found the MBA had a bad trackpad cable, replaced, and the screw from the heatsink is missing. WIll replace.

    Any updates, apart from purchasing a new motherboard?
     
  8. klflv macrumors newbie

    Joined:
    Oct 27, 2016
    #8
    Same thing Here MacbookAir6,2 mid2013. Don't know (yet) about water damages as I bought it second hand. Yesterday gave it away to Apple for tests. Now I have a week to wait for answer.
     
  9. randy2k macrumors newbie

    Joined:
    Oct 19, 2016
    #9
    Will be interested to hear what Apple Genius prescribes. I am thinking that the only repair, if nothing else works, is a new logic board. Please update this thread when you get the results!
     
  10. klflv macrumors newbie

    Joined:
    Oct 27, 2016
    #10
    Yes. Apple said the only solution is to replace logicboard (510€ in my country). Today I gave the computer to a independent workshop to see if they can trace down the problem and maybe do some soldering.
     
  11. randy2k macrumors newbie

    Joined:
    Oct 19, 2016
    #11
    That would require have the schematics of the board. While not easy on a multi-layered board, this appears to be a failing sensor. Would be good to know which one it is and where to get a replacement, if possible.
    Please keep us informed.
     
  12. klflv macrumors newbie

    Joined:
    Oct 27, 2016
    #12
    Some update:

    In the workshop they said that the damage is beyond economically logic repair. It needs a new board. So I found a board, swapped it myself and much to my surprise - the error was still there (literally the same error codes in ASD). So I tried to eliminate the problem by disconnecting all the components one by one. And guess what - apparently the camera confuses SMC, so my MBA with the old board runs fine with camera disconnected. Apple diagnostics gives only error code for camera (as it is not connected), ASD gives no SMC errors, in OS everything seems to work fluently, except I am not sure about hardware fan control - in Macs Fan Control CPU temps go up as high as 80-90C (on cpu load) and ~45C-50C at idle, but the fan spins at lowest speed (~1200) all the time. So for the purpose of not burning anything I keep the Macs Fan control on logic settings, so the CPU wont go much above 65C. Could anybody tell me what are the temps for fully functioning MBA 6,2 i5 1,3ghz at idle and let's say running Geekbench 4 at the end of tests. And at what temperature (CPU PECI) the fan speed starts to increse. Thank You!
     
  13. randy2k macrumors newbie

    Joined:
    Oct 19, 2016
    #13
    With this problem I should have practiced the KISS method (Keep It Simple Stupid), which I usually do. In addition to what I stated earlier, I also ran diagnostics and always got the same errors of the power adapter - it wasn't connected, and a possible audio hardware error. I forgot to mention earlier that there is no sound.
    I swapped the logic board with another MacBook Air A1466 and fortunately found the board was OK. After researching again I decided the IO board could be the culprit. My experience has showed with liquid spills, water nearly always enters the open connections, like the USB, and can short logics.
    So I used your method and disconnected the cables, not all of them, and found it wasn't the keyboard or trackpad either. I then ordered an IO board, it was changed and still had the same problem - high kernel activity of 350+% and fan noise. Following your results with the camera, I then unplugged it and the problem persisted. Finally I disconnected the microphone and bingo, no more high kernel activity, the fan did not go on, iStats showed a 54C degree CPU and 45C degree SSD, previously registering 90C due to being hammered by the kernel.

    Lessons learned? 1. always check the simplest and least expensive suspect parts first 2. make a connection between the the diagnostics and the symptoms. I won't know if the defective microphone fixes the sound problem until it is replaced but looking at the microphone connection much earlier would have saved me time. 3. Not all third party repair houses are good, or honest. This defective Macbook Air had been looked at by another company
    which had dried the system after the spill and then returned. I was asked to look at it after it started with the fan activity. I had to order two cables because the connectors had been damaged, probably from bad handling. But after looking at the microphone, which was physically mangled, I might even guess that good parts were substituted with partially damaged, lesser qualified parts. I don't have proof, but it would be difficult for an amateur to damage connectors on these small and fragile cables.

    The microphone will be ordered tomorrow and I will update when it has been changed.
     
  14. randy2k macrumors newbie

    Joined:
    Oct 19, 2016
    #14
    --- Post Merged, Nov 29, 2016 ---
    Changed out the microphone and voila, no more high temps, high kernel %, and constant fan at 100%. Now I only have the problem of no sound...
     

Share This Page