3D touch preventing Safari links from opening (non-deep) taps

Discussion in 'iPhone Tips, Help and Troubleshooting' started by hofnar, Oct 2, 2015.

  1. hofnar macrumors regular

    hofnar

    Joined:
    Feb 12, 2006
    Location:
    Brooklyn, NY
    #1
    I have a 64 GB Silver 6S Plus.

    I've read a few sites about this, but I've not been able to find this in the forums. If someone knows of the thread, can you please share it? I'm just looking for a fix .

    Occasionally when I click a link in Safari or mail (normal/non-deep) The phone does nothing. The wheel at the top wont spin. I know the phone registers my tap because the link or image has the gray box that appears when you touch it. I can do the whole deep touch (pop/snap thing), and the website loads, but nothing happens with a normal tap.
     
  2. bheathain macrumors member

    Joined:
    Oct 5, 2015
    #2
    I have seen the same thing. I have to "click" (touch) a few different ways to get a link click to register. I guess I chalked it up as a 3D touch bug that will hopefully get fixed.
     
  3. DrewDaHilp1 macrumors 6502a

    DrewDaHilp1

    Joined:
    Mar 29, 2009
    Location:
    All Your Memes Are Belong to US
    #3
    Same thing here. Having to lightly touch the link to get it to open.
     
  4. RabbitLuvr macrumors 6502

    RabbitLuvr

    Joined:
    Oct 20, 2011
    Location:
    Kansas City
    #4
    I'm also experiencing this. It's really annoying and hope it gets addressed in an iOS update.
     
  5. hofnar thread starter macrumors regular

    hofnar

    Joined:
    Feb 12, 2006
    Location:
    Brooklyn, NY
    #5
    Thank you all for replying! I didn't see this on a thread after I searched and I wasn't sure who to ask. I did a system restore and set it up as a new phone and still I have the problem.
     
  6. J.C macrumors 6502

    Joined:
    Nov 12, 2008
  7. Brownbox88 macrumors newbie

    Brownbox88

    Joined:
    Sep 21, 2012
    Location:
    FL
    #7
    Happening to me too. I notice it happens less often when sensitivity for 3D Touch is increased
     
  8. garycoleman2 macrumors member

    Joined:
    Sep 21, 2010
    #8
    I have the same problem too and I'm not sure if it is a software or hardware issue. It does it it intermittently. However if I disable 3D Touch the problem never happens.
     

Share This Page