Resolved 3G 4.2.1 Jailbreak & Unlock Questions/Problems

Discussion in 'Jailbreaks and iOS Hacks' started by drummingcraig, May 11, 2011.

  1. drummingcraig, May 11, 2011
    Last edited: May 12, 2011

    drummingcraig macrumors 6502a

    drummingcraig

    Joined:
    Sep 19, 2007
    Location:
    "Armpit of the South"
    #1
    I have an iPhone 3G running 4.2.1 (5.15.04 Baseband) that I am trying to jailbreak and unlock for a friend of mine so he can sell it.

    I am trying to use Redsnow 0.9.65b which is what I *thought* was the proper way to go. I also downloaded iPSW iPad1,1_3.2.2_7B500 which I also read was required for phones that were on the 5.15 baseband.

    When I attempt to run the jailbreak it won't go thru at all. Afterr following the prompts for launching the phone into DFU mode I just get a "error" and the phone goes dead (it will power back on).

    Any advice as to what may be the issue and/or alternative ways to accomplish this?
     
  2. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #2
    Are you loading in the iPhone1,2_4.2.1 firmware into Redsn0w?
     
  3. drummingcraig thread starter macrumors 6502a

    drummingcraig

    Joined:
    Sep 19, 2007
    Location:
    "Armpit of the South"
    #3
    Well not exactly. When I opened Redsnow and it asks for the PSW image I was pointing it at the iPad1,1_3.2.2_7B500 package as I was under the impression that is what I needed to do for the different baseband.

    Do I need to point it at the current PSW first?
     
  4. awadeee macrumors 68020

    awadeee

    Joined:
    Jan 21, 2011
    Location:
    Canada
    #4
    Why are you using such an old version? I don't even think it's untethered for 4.2.1.

    Go download the newest version of Redsn0w and the 4.2.1 firmware from:

    http://www.felixbruns.de/iPod/firmware/

    :)

    EDIT: You can't get Redsn0w from that link. It's just for the firmware, sorry for the misleading phrase.

    Do a google search for Redsn0w.
     
  5. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #5
    You need to point at the 4.2.1 firmware when running redsn0w. iPad firmware on your PC is only for redsn0w to wrap its baseband.
     
  6. drummingcraig thread starter macrumors 6502a

    drummingcraig

    Joined:
    Sep 19, 2007
    Location:
    "Armpit of the South"
    #6
    That's what he has on is 3G so thats what I was going with. As for 4.2.1 not being untethered, I have 4.2.1 on my iP4 and it is jailbroken (untethered) with Greenpoison so I don't think thats the issue.

    OK I will try that. I just wanted to make sure that we could not only jailbreak but unlock his 3G and the article I was reading made it sound like I needed the older iPad firmware to do that on the 3G (I am new to the unlocking thing as I haven't done that to my Greenpoisoned iP4 yet).
     
  7. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #7
    Once the jailbreak is done, your friend phone will have the 06.15 baseband. You will then open Cydia and install ultrasn0w 1.2.3 to unlock the phone. If you use T-Mobile, please make sure to disable 3G.
     
  8. drummingcraig thread starter macrumors 6502a

    drummingcraig

    Joined:
    Sep 19, 2007
    Location:
    "Armpit of the South"
    #8
    Got it taken care of!

    Thanks to all for the help. :)

    Craig
     

Share This Page