3g 8gig Ipod Touch home Wifi Help!

Discussion in 'iPod touch' started by flippapabear, Jan 6, 2010.

  1. flippapabear macrumors newbie

    Joined:
    Jan 1, 2010
    #1
    Hey,
    i have an 8gb ipod touch and a wrt 110 router at home.i cant connect to it. ive tried many of the possible solutions from other threads and decided to make my own. my touch can connect to other wifis so im thinking its the settings on this router. Ive tried no pw, wep, and wpa2 and its been saying unable to join "SSID" and the few times i did get it to connect, the router didnt know it was connected when i checked the client table. On this router we can get everything else to connect fine.

    please help!
     
  2. jampat macrumors 6502a

    Joined:
    Mar 17, 2008
    #2
    I can't get my touch to connect to some routers, it just won't work. Changing routers solves the problem. I am not sure if it is a problem with the touch or whether some routers don't implement standards properly and most computers don't use the problem areas.
     
  3. Ironworker808 macrumors regular

    Joined:
    Jun 13, 2009
    #3
    Sorta the same situation here, only my wife's 8GB iTouch says it's connected to our home WiFi network but it won't connect to any apps that require WiFi. Pandaora, App store, iTunes, etc.

    Tried turning WiFi off and on, reconnecting, and even restoring. Nothing works. Any suggestions would be greatly appreciated.

    EDIT: It's an iPod Touch, not an iTouch.:eek:
     
  4. iRawkMac macrumors newbie

    iRawkMac

    Joined:
    Aug 12, 2009
    #4
    Easy solution guys. Those routers are Wireless-N routers. The chips in the iPod Touch don't have N-Class capabilities, they have 802.11b/g not 802.11b/g/n. The new iPhones are said to have it next though. So basically what I'm sayin is your routers are transmitting a 5GHz only signal and you need a 2.4GHz signal to be able to use the iPod Touch which is a basic 802.11b/g router. The cheapo's. Haha

    **Edit** If you want a quick fix, I would suggest a dual-band router such as the new Airport Extreme's or Time Capsules which transmit in 5GHz and 2.4GHz simultaneously. That's what I use and have my computers connect to the 5GHz network and my iPod connects to the 2.4Ghz connection. It's supposed to be "cleaner" internet because there is less interference on the 5GHz network from things like cordless phones and stuff like that.
     
  5. Shieldsboy macrumors newbie

    Joined:
    Jan 6, 2010
    #5
    I am having the same problem - Ipod Touch "sees" the wireless signal from my Minitar Wifi Router but will not connect or is so slow it eventually drops out (regardless of the apparent strength of the signal).

    However, if I walk out to the street and find any "unlocked" wifi network i get good performance.

    Yet my router is several years old - supports B and G but certainly not N.

    As a result of this problem I am about to replace the Minitar - any suggestions for a low-cost modem/router/wireless to purchase?

    Don
     
  6. iRawkMac macrumors newbie

    iRawkMac

    Joined:
    Aug 12, 2009
    #6
    Have you tried the possibilities of firmware upgrades for your router?
     
  7. Shieldsboy macrumors newbie

    Joined:
    Jan 6, 2010
    #7
    Yes,

    I checked that and made sure I had the latest version - dated 08/09/05.

    Well before the Touch came on the scene!

    Don
     
  8. Shieldsboy macrumors newbie

    Joined:
    Jan 6, 2010
    #8
    What is particularly concerning about this problem is that many Ipod Touch users appear to be having the problem.

    Just read other forums and you will see the problem regularly mentioned.

    And I'd venture to suggest that in virtually all cases where the problem occurs, other standard equipment works quite happily with that router (in my case I have been running a standard laptop utilising the routers DHCP service with no problems).

    And yet I cannot find any explanation - surely Apple have the resources to investigate and advise us on the problem.

    It clearly seems to be related to some specific routers so, if I want to update my router, what do I buy?

    It seems i just have to guess and hope for the best!

    I think it is time Apple got their act together on this problem.

    Don
     
  9. Shieldsboy macrumors newbie

    Joined:
    Jan 6, 2010
    #9
    I have had a feeling that the problem lay in the DNS area, so this morning did some "field" testing!

    I walked down the main street of our suburb monitoring the Touch to see when it gained contact with an non-secured wifi network.

    I found 4 and I connected with each with very good access speed.

    However, the one difference between my hifi network settings and these networks was the content of the "Search Domains" box under the DHCP section of the IP Address.

    Entries in the field would be, for example, "Belkin" or "Netgear" and other such names (not ip numbers).

    I am now trying to identify what should be in the Search Domains box, and how to get my router to put it there?

    Is it the use of Dynamic DNS? What are the implications if you have a static IP address?

    Any ideas would be very much appreciated.

    Don
     
  10. pilotrtc macrumors regular

    Joined:
    Dec 4, 2008
    #10
    I just checked my Search Domains entry and it was the DNS of my service provider. It was in this format:

    <city>.<service provider>.com

    A Search Domain refers to the Domain Name Server the browser should use when looking up a URL. It converts http://www.google.com to http://209.85.129.104/

    Try the IP address above when you are connected to a network when a regular URL doesn't work.
     
  11. albush macrumors newbie

    Joined:
    Jan 9, 2010
    #11
    I have been experiencing some problems with wifi at home, too.
    I have an 3rd gen, 8gb ipod touch. At first, I couldn't even access the internet. Turned out the ipod touch can't handle WPA-PSK [TKIP] + WPA2-PSK [AES] encryption, so i downgraded to WPA2-PSK [AES]. That allowed me access, but at ridiculously slow speeds. Get up and brew a pot o' coffee while waiting for the pic in an email attachment slow. (When mobile gmail even bothered to open). Frustrating to say the least.
    Then I brought it into work, connected to our work wifi, and got blazing fast speeds.
    This made me think it was a router issue. The work router is dual band, b/g ad b/g/n. I was only able to connect to the b/g band, obviously, and that made all the difference. So at home, I dropped my speed down to b/g only, (at the expense of streaming video on my laptops) and now my ipod touch flies.
    Guess the solution is a dual band router.
     

Share This Page