3G and edge not working on 3Gs iphone

Discussion in 'iPhone' started by wfielder84246, Jun 21, 2009.

  1. wfielder84246 macrumors member

    Joined:
    Feb 17, 2008
    Location:
    UK
    #1
    Just got the new iphone 3gs yesterday and i can't get the 3g and edge to work. My settings are all correct (idata...) and have rung o2 who keep saying try turning the unit on and off.... Any ideas how to get it working??? mms and visual voicemail are working... hmm
     
  2. 2259 macrumors member

    Joined:
    Jul 13, 2008
    #2
    Are you in 3G area?

    Has your SIM got '3G' on the back after the long numbers?

    Have you removed your SIM, put it in another 3G phone to see if its the SIM thats at fault?
     
  3. wfielder84246 thread starter macrumors member

    Joined:
    Feb 17, 2008
    Location:
    UK
    #3
    yeah i am in a 3g area, sim card is fine... :S i upgraded from o2 simplicity if that makes a difference??
     
  4. 2259 macrumors member

    Joined:
    Jul 13, 2008
    #4
    Either:

    Take it to an Apple store and get a Genius to look at it

    OR

    Take it to O2 store, and get them to try another SIM card in it.
     
  5. rhealy2002 macrumors newbie

    Joined:
    Jun 21, 2009
    Location:
    London, England
    #5
    Shouldn't make a difference

    I know I'm pretty new to this place, but been reading the forum for about 3 years now, as a guest, any hows.

    My dads Simplicity plan worked great with my original iPhone, edge etc since he had unlimited data plan, but just upgraded his Simplicity to get my iPhone 3GS lol, so not tested it yet with my 3G phone, but his not complained, maybe he hasn't noticed it, but I know o2 txt me about updating settings on my original iPhone, so make sure your settings are correct in Cellular Data

    APN: idata.o2.co.uk
    Username: vertigo
    Password: password,

    any changes to contracts can take upto 24 hrs etc reps usually say

    hope this helps
     

Share This Page