3g data not working after JB!

Discussion in 'Jailbreaks and iOS Hacks' started by AznGunner, Jan 21, 2012.

  1. AznGunner macrumors newbie

    Joined:
    Aug 20, 2011
    #1
    several posts indicate Sbsettings as the culprit. 3g is showing on the status bar, but I'm not connected to data. I've tried toggling cellular data from settings. I've reset network settings. I even tried to remove Sbsettings, but got residual icons left on the phone, but still no data. What is the fix!!
     
  2. kalex macrumors 65816

    Joined:
    Oct 1, 2007
  3. AznGunner thread starter macrumors newbie

    Joined:
    Aug 20, 2011
    #3
    sprint
     
  4. kalex macrumors 65816

    Joined:
    Oct 1, 2007
    #4
    i did same thing. In my case I was able to get it back by uninstalling sbsettings, turning off voice, data and roaming and turning them back on.

    reset network settings should also work. worse case - restore and rejailbreak again
     
  5. AznGunner thread starter macrumors newbie

    Joined:
    Aug 20, 2011
    #5
    when you uninstalled sbsettings, did you do it through cydia? and did you get leftover icons?

    I might have to re-jailbreak again....but is sbsettings the thing that did it?
     
  6. kalex macrumors 65816

    Joined:
    Oct 1, 2007
    #6
    yes i install and uninstall everything jailbreak related via cydia. no left over icons

    yes its sbsettings that caused it. once u fix it, go into sbtsettings and disable 3g toggle so u don't hit it by accident
     

Share This Page