3g data not working after JB!

AznGunner

macrumors newbie
Original poster
Aug 20, 2011
10
0
several posts indicate Sbsettings as the culprit. 3g is showing on the status bar, but I'm not connected to data. I've tried toggling cellular data from settings. I've reset network settings. I even tried to remove Sbsettings, but got residual icons left on the phone, but still no data. What is the fix!!
 

kalex

macrumors 65816
Oct 1, 2007
1,330
56
i did same thing. In my case I was able to get it back by uninstalling sbsettings, turning off voice, data and roaming and turning them back on.

reset network settings should also work. worse case - restore and rejailbreak again
 

AznGunner

macrumors newbie
Original poster
Aug 20, 2011
10
0
i did same thing. In my case I was able to get it back by uninstalling sbsettings, turning off voice, data and roaming and turning them back on.

reset network settings should also work. worse case - restore and rejailbreak again
when you uninstalled sbsettings, did you do it through cydia? and did you get leftover icons?

I might have to re-jailbreak again....but is sbsettings the thing that did it?
 

kalex

macrumors 65816
Oct 1, 2007
1,330
56
when you uninstalled sbsettings, did you do it through cydia? and did you get leftover icons?

I might have to re-jailbreak again....but is sbsettings the thing that did it?
yes i install and uninstall everything jailbreak related via cydia. no left over icons

yes its sbsettings that caused it. once u fix it, go into sbtsettings and disable 3g toggle so u don't hit it by accident
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.