3G iPad2 constantly says "No Service" ?

Discussion in 'iPad' started by arcsbite, Apr 2, 2011.

  1. arcsbite Guest

    Joined:
    Jan 14, 2006
    #1
    anyone had this?

    I had a 3g iPad 1 and upgraded to the iPad 2

    when I put my microsim in the iPad 2, no mater what I do I get "No Service"
    when I put the sim back in my iPad 1 or in my iPhone 4 I instantly get full 3g signal

    I called my provider (3mobile) and they say it's a device issue, I'm sure it's a setting but I can't seem to figure it out
     
  2. mikethebigo macrumors 68000

    Joined:
    May 25, 2009
    #2
    Reboot, try a full restore, if it still doesnt work exchange it.
     
  3. arcsbite thread starter Guest

    Joined:
    Jan 14, 2006
    #3
    tried reboot.
    was trying to avoid a restore but will give it a go now
    cheers
     
  4. jenlevin macrumors regular

    Joined:
    Feb 21, 2011
    Location:
    Sunny Florida
    #4
    try to reset network settings and toggle airplane mode off/on before you bother with a restore
     
  5. arcsbite thread starter Guest

    Joined:
    Jan 14, 2006
    #5
    Thanks
    gave it a go but no change.
     
  6. bowlerman625 macrumors 68020

    bowlerman625

    Joined:
    Jun 17, 2009
    Location:
    Chicago, IL area
    #6
    I had that happen and needed a new sim card to fix the problem. Once I did that things were good.
     
  7. Loopy65 macrumors 6502a

    Loopy65

    Joined:
    Jun 6, 2008
    Location:
    Wales, UK
    #7
    Think it could be device issue .. I too had an iPad 1 and popped my Three sim from there into my iPad 2 with no problems whatsoever .. straight swap.

    Hope you're able to get it sorted without too much trouble
     
  8. arcsbite thread starter Guest

    Joined:
    Jan 14, 2006
    #8
    Thanks so much for the help everyone :)

    problem solved.
    I resoted my iPad and service came back...until
    I clicked "Restore from backup" and used my iPad back up which had always been fine.
    it restored fine and instantly went to no service :(

    so I've just had to use a fresh restore, not great but not a major issue and I have full service back

    thanks again everyone, one of the many reasons I love this forum
     
  9. mikethebigo macrumors 68000

    Joined:
    May 25, 2009
    #9
    Glad the restore worked. Sorry you have to start from scratch, but hopefully it won't take too long to get everything all set up again. Just pretend you have a brand new iPad! :D
     
  10. bmat macrumors 6502

    Joined:
    Nov 24, 2004
    Location:
    East Coast, USA
    #11
    If the problem comes back, I'd visit Apple. I had the same thing with my iPhone 4, and it kept coming back. Apply just replaced it.
     
  11. Zcott macrumors 68020

    Joined:
    Oct 18, 2009
    Location:
    Belfast, Ireland
  12. arcsbite thread starter Guest

    Joined:
    Jan 14, 2006
    #13
    yeah it was/is
    I spoke with 3 yesterday in length...not much use lol

    will keep an eye on it but fresh instal seems to be the key so far
     
  13. rworne macrumors 6502

    Joined:
    Jul 23, 2002
    #14
    I had the same issue with a warranty-replacement 1st Gen iPad.

    Crapped out 3G after a restore from backup. Lucky in my case the second time was a charm and it worked then.
     
  14. Phil oz macrumors newbie

    Joined:
    May 5, 2011
    #15
    MY SOLUTION:
    Got a TPG micro sim for my new ipad 2 and had the same issue " no service" for 3 weeks despite the simcard being properly activated. Finally I called TPG and they solved the issue immediately: in Settings, cellular data, APN setting: must type INTERNET (capital letter) instead of CONNECTME which is there by default. Then switch OFF the ipad by pushing/holding the off button for a few seconds *the "slide to switch off" appear on the screen) and then switch on again.

    For me it worked perfectly, after a few seconds I got the 3G network.

    hope it helps...
     
  15. gigemzach macrumors 6502

    Joined:
    Dec 31, 2009
    Location:
    San Antonio, Texas
  16. Kmo679 macrumors newbie

    Joined:
    Aug 17, 2013
    #17
    Simple fix....

    Under settings...go to "cellular data" and make sure this is set to OFF. I was having the same problem for a year and finally poked around to figure it out. Even did a restore that didn't fix it. And just realized....wait...no service is related to the DATA not wifi. And sure enough, when I turned the cellular data off, No Service is gone!
     

Share This Page