3G network (internet usage) not working after Jailbreak

Discussion in 'Jailbreaks and iOS Hacks' started by Maynerd, Jul 7, 2009.

  1. Maynerd macrumors regular

    Joined:
    Jan 4, 2007
    #1
    Hey folks,

    I'm hoping someone might be able to help me here.

    For some reason after the JB I'm unable to connect to the internet using the 3G network.

    I'm able to connect via Edge and via Wifi but unable to connect via 3G.

    When I open safari I get the following when trying to go to a website:

    Cannot Open Page
    Safari cannot open the page because it is not connected to the Internet.

    When I open mail I get the following:

    Cannot Get Mail
    The connection to the server failed.

    Anyone have an idea on what's wrong?
     
  2. TSX macrumors 68030

    TSX

    Joined:
    Oct 1, 2008
    Location:
    Texas
  3. Maynerd thread starter macrumors regular

    Joined:
    Jan 4, 2007
    #3
    Yup...same problem. :(
     
  4. Maynerd thread starter macrumors regular

    Joined:
    Jan 4, 2007
    #4
    Ok figured it out. Apparently I turned off Edge.

    Didn't realize I needed edge on when I'm using 3G network.
     
  5. taitofu macrumors newbie

    Joined:
    Jul 8, 2009
    #5
    Jailbroke with redsn0w 3.0 on my iPhone 3G

    Hi, I'm a newbie here, and to jailbreaking.

    I've had my iPhone 3g for a year now, and have decided to jailbreak. I've researched extensively, and have run into the following problems with no resolution.

    1) I have a 6 GB data plan with Rogers, and now my iPhone will not allow me to connect to the internet over 3G. I can not make phone calls.

    I CAN connect over wifi. After jailbreaking, it should work from my understanding, 3g, phone calls, and wifi, etc.

    [I do not have the option to turn off edge, as Maynerd has mentioned. I have jailbroken twice. The first time I jailbroke, I ran into this problem. So, I restored to factory settings, and re-followed the regular steps.]

    CAN SOMEONE PLEASE ADVISE AS TO HOW TO TROUBLESHOOT THIS PLEASE? THANK YOU.
     
  6. rembot macrumors member

    Joined:
    Jul 29, 2009
    Location:
    ottawa
    #6
    I got the same problem. I did the jailbreak and now i cant receive or make phone calls, or access the 3g network.

    PLus, every app i got from the app store wont open, then open for a second and close right away. But that app problem did happen before, how do i get rid of that too?
     
  7. Yrjan macrumors newbie

    Joined:
    Jun 15, 2010
    #7
    Anyone find a fix for this? My 3g quit working all together. It starts acting up where I would loose it for a while, then it would come back but it is gone for good now. I can turn off 3g in the network settings menu and still use all the functions via Edge network, but this is way too slow. any help?
     
  8. Yrjan macrumors newbie

    Joined:
    Jun 15, 2010
    #8
    FIXED!

    Called AT&T right after posting previous post and told them that I was having trouble connecting to 3g network and that I needed them to "reprovision" my phone. AT&T rep said no problem, turn off phone, I turned off, about 10 seconds later I was told to turn on again and toggle 3g on. Works like a charm. Evidently there is sometimes a glitch with-in the phone itself that she could not explain to me that causes connectivity issues. I dont care, my iPhone is back to its ugly self again and I am going to go barf in a bowl and eat it. Good luck everyone!
     

Share This Page