3G not working on iPhone 4

Discussion in 'iPhone Tips, Help and Troubleshooting' started by anetoiu, Jun 5, 2011.

  1. anetoiu macrumors member


    Oct 29, 2010
    I have an iPhone 4 locked on the 02.10.04 bb and unlocked with gevey SIM.
    3G is not working at all, my phone is working on EDGE. My carrier is promissing more than 7mbps and I barely get 0.2mbps. They sent me the APN which I was supposed to write baseband and nothing else in the other fields. I also tried these methods:

    -resetting network settings
    -resetting all settings
    -tried the unlockit website with custom APN
    -hard and soft reset
    -took my bicycle and tried connecting to 3G in multiple spots in my city

    I didn't try restoring it to factory settings and setting it as a new iPhone because I'm not the first owner of this iPhone and I never set it as a new iPhone. I will do that when I'll come back home but I need to know if there are other methods that I should try. (also, please, avoid telling me to get an iPhone replacement or call Apple because there is absolutely no Apple store in my country).

    I bought this gevey SIM from someone from a local forum. I tried his gevey sim in my iPhone with his carrier SIM (I noticed we're on the same carrier - Cosmote Romania) and the 3G appeared next to the carrier name but after I unlocked it on my iPhone, I only see EDGE, the 3G never turned on.
  2. Applejuiced macrumors Westmere


    Apr 16, 2008
    At the iPhone hacks section.
    Make sure the iphone 4 is compatible with your carriers 3G bands.
    If not restore to the latest firmware and try the gevey again.
  3. Wildcat1221 macrumors newbie

    Jun 5, 2011
    Try making sure the 3G is active. Go: Settings- General- Network. Now make sure "Enable 3G" is set to "ON".
  4. anetoiu thread starter macrumors member


    Oct 29, 2010
    It is compatible because as I said, I know someone with the same device on the same network with a gevey sim and he is able to activate the 3G. I also made sure that I activated both the 3G and data roaming and I also have the latest firmware and the 3G is still not working but it worked once with that guy's sim and gevey sim on the same network. I'm only able to navigate through edge.
  5. t01 macrumors newbie

    Mar 12, 2013
    Found a solution, don't know if someone needs it now. Anyway I-m going to share it. All this steps need to be done while connected to wifi.

    1. You have to activate Data Roaming on General > Cellular > Data Roaming.
    2. You go on Safari to http://unlockit.con.nz. Choose Create APN, choose your country and carrier and click on Create APN.
    3. You will go to a iOS profile. Accept it and that's it.

Share This Page