3G on Tmobile?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mediamogul, Jun 24, 2008.

  1. mediamogul macrumors newbie

    Joined:
    Jun 9, 2008
    #1
    Greetings, as the big day approaches I wonder if the magnificent minds will be able to jailbreak the new iphone for use on other networks like Tmobile? The wife has an iphone that we picked up on ebay and it works excellent with tmobile but what about the new 3g version?

    If it is jailbroken will it be with the newest software? I have been shrugging off getting the phone but I can no longer wait as i can really use it for work.

    I would love to know all your thoughts. thanks
     
  2. aross99 macrumors 68000

    aross99

    Joined:
    Dec 17, 2006
    Location:
    East Lansing, MI
    #2
    I'm sure someone will work out the jailbreak for the iPhone 3G, but keep in mind that T-mobile doesn't have a nationwide 3G network, so there is not real reason to get the iPhone 3G if you aren't going to use it with AT&T...
     
  3. g4cubed macrumors 6502a

    g4cubed

    Joined:
    Jun 2, 2004
    #3
    Hell AT&T doesn't either. ;)
     
  4. mediamogul thread starter macrumors newbie

    Joined:
    Jun 9, 2008
    #4
    What about using mobileme etc? dont i need the new iphone with the software to be able to use that?

    I actually spoke to Tmobile and they are rolling out 3G in LA in late Sept. according to them that is.
     
  5. transam7816 macrumors regular

    Joined:
    Mar 7, 2008
    #5
    the 2.0 software will have the mobileme app in it. which means all current iphones just need to upgrade to 2.0 when it comes out. as far as the 3g iphone being on tmobile..it will work but the 3g part of it wont since tmobile is gay and has unique bands unlike any other network...and the iphone doesn't support it so no 3g for us tmobile customers =/
     
  6. mediamogul thread starter macrumors newbie

    Joined:
    Jun 9, 2008
    #6
    ok so to upgrading to the 2.0 software, will that mess up the ability to use tmobile on a current phone with 1 1 4?
     
  7. Chow7 macrumors member

    Joined:
    Oct 24, 2007
    #7
    yes. Do not upgrade to 2.0 until it is confirmed safe to work with Unlocks and T-Mobile.
     
  8. kvasir macrumors regular

    Joined:
    Oct 9, 2007
    #8
    Bad news everyone, you won't be able to use that iPhone 3G on T-Mobile's 3G network. T-Mobile has decided to use the 1700mhz band, which the iPhone does not support. Unless Apple adds this to future iPhones, you're stuck on 2.5G EDGE.

    http://www.phonescoop.com/carriers/carrier.php?c=5

    I'm sure they'll find a way to jailbreak 2.0 so you guys can use it on T-Mobile, but we'll have to see when ATT starts selling no contract iPhones.
     

Share This Page