3G problems after updating my iPad Mini to iOS 7

Discussion in 'iOS 7' started by Orka, Sep 26, 2013.

  1. Orka macrumors regular

    Joined:
    Dec 24, 2012
    Location:
    Moscow, Russia
    #1
    I sometimes go to my countryside house where 3g coverage is not very good (3g signal is about 3 bars on average, and 2g is about 4 bars) but on IOS6 it always kept on 3g and internet was relatively fast and very usable, but now on IOS 7 it keeps switching to 2g network constantly.

    Even if it shows it's on 3g, and it does that often, right when i click ANY link it INSTANTLY resets to 2 G, and it's going back and forth like that to the point that internet is extremely slow and unusable.
    Anyone experienced this?
     
  2. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #2
    Try settings > general > reset > reset network settings.

    note: this will also forget wifi passwords so you may want to have them handy before you do this.
     
  3. Orka thread starter macrumors regular

    Joined:
    Dec 24, 2012
    Location:
    Moscow, Russia
    #3
    Already tried with no help.
     
  4. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #4
    Do you have iCloud backup enabled? I think it's required for photo stream.
     
  5. Orka thread starter macrumors regular

    Joined:
    Dec 24, 2012
    Location:
    Moscow, Russia
  6. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #6
    Shoot Sorry. I replied to the wrong thread.
     
  7. Osko macrumors newbie

    Joined:
    Sep 29, 2014
    #7
    Hey ive got this problem??? U found solution?
     
  8. Orka thread starter macrumors regular

    Joined:
    Dec 24, 2012
    Location:
    Moscow, Russia
    #8
    I bought small mobile wifi router (huawei e5776 to be exact) where i can force use of only 3g, that's the only solution i could find.
    Unfortunately Apple allows very limited network options in IOS.
     

Share This Page