3G Wi-Fi problem

Discussion in 'iPhone' started by linfeld, Feb 11, 2009.

  1. linfeld macrumors newbie

    Joined:
    Jan 30, 2009
    #1
    Even though I have a Wi-Fi connection at home, my iPhone still insists on using 3G. Wi-Fi is on and shows my local network. But 3G is still being used. If I turn off 3G, the iPhone switches to Edge. How do I force my iPhone to use my local Wi-Fi connection?
     
  2. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #2
    Is your WiFi encrypted? Maybe your encryption key is off?

    When you look at WiFi in Settings, does it have an IP address or an auto-assigned one (ex. 169.254.x.x)?

    If either of these apply, your iPhone will default to cellular, hence the 3G/Edge. :)
     
  3. Katuls macrumors member

    Joined:
    Feb 2, 2009
    #3
    start at the basics: is your wifi on?


    -is there a passcode/encrypted?
     
  4. linfeld thread starter macrumors newbie

    Joined:
    Jan 30, 2009
    #4
    3G Wi-Fi problem

    There was no IP information listed for my network. Actually, there was no information at all listed. I tried entering the IP address of my Time Capsule. That made no difference. On a whim, I told the iPhone to forget my network. This did the trick. The iPhone immediately connected to my network without any problems. All the settings for DHCP are filled in. Thanks for helping me figure this problem out.
     

Share This Page