3G with 2.1: Apps are starting - and closing immediately

Discussion in 'iPhone' started by thorbenh, Sep 18, 2008.

  1. thorbenh macrumors member

    Joined:
    Mar 23, 2008
    #1
    Hi!

    i have an 16GB 3G with the 2.1 FW. After a couple of days I had the same problems like with 2.0.2:
    3rd party applications from AppStore are starting for a second and then closong immediately... I always thought it is a problem with 2.0.2 put apperently it is the same with 2.1.

    Am I the only one with that problem?
    by the way: I did a complete Reset and Reinstall after the update to 2.1 without restoring an old backup.

    Bye

    th
     
  2. DreamPod macrumors 65816

    Joined:
    Mar 15, 2008
    #2
    All Apps are doing this? Or just a couple? It could be a bug in the App.
     
  3. synagence macrumors 6502a

    Joined:
    Jul 23, 2008
    #3
    There are quite a few apps which don't work in 2.1 ...

    Simply because while the developers had 2.1 betas before we did ... they couldn't submit updates to the apps to the store for approval until the final 2.1 was given to them ... so it will be a week or two before a whole raft of updates comes up
     
  4. thorbenh thread starter macrumors member

    Joined:
    Mar 23, 2008
    #4
    I happens to all of my 3rd party applications:

    Facebook
    GPS Tracker
    Face Melter
    Brain Tuner
    Enigmo
    Visual Radio
    Air Sharing
    Shazam
    NetNewsWire
    Fuzzle
    WifiFiFum

    I can see the apps for approx 3 seconds until they close ;(
     
  5. browndhb macrumors newbie

    Joined:
    Sep 18, 2008
    #5
    I had the same issue and solved it by deleting one of my free apps, and re-downloading and installing through the iPhone App store. I have no idea why this worked, or what went wrong in the first place.
     
  6. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #6
    I have this problem from time to time and it is caused by the RAM being full. Restarting the phone usually solves the problem.

    TEG
     
  7. Ninja Dom macrumors 6502

    Ninja Dom

    Joined:
    Feb 12, 2007
    #7
    I also had this problem last week when I was on 2.0. I'm now on 2.1.

    Original 2G iPhone. I was roaming in Spain and had:

    *All Apps closing immediately after launching.
    *Purchased video and music content from iTunes could not be played.

    Rebooting the phone never worked. I waited until I got back to the UK where I could comfortably get a data connection. I then ran the App Store and found I had 3 updates to some of my apps. I chose to update them and had to put my iTunes password in. After that everything worked again as normal.

    It seems like the iPhone had somehow "forgot" that it had permission to run the apps, music and videos that I legitimately downloaded from iTunes while I was Roaming (Data Connection Off while roaming). Putting my password back into the iTunes App store made the phone remember that it did have permission to do everything.
     
  8. DreamPod macrumors 65816

    Joined:
    Mar 15, 2008
    #8
    If it always happens with all apps and turning the phone off and on doesn't fix it, you have a defective iPhone, or at least something is horribly wrong with it. You should take it into the Apple Store and have their Geniuses look at it.
     
  9. tdevers macrumors regular

    Joined:
    Apr 21, 2008
    #9
    Facebook and TubeStatus both do it. Facebook isn't much of a problem, but knowing what's going on with the tube is handy.
     
  10. schubes macrumors regular

    schubes

    Joined:
    Jul 14, 2008
    Location:
    British Columbia
    #10
    All my apps are doing this all of a sudden except for main stuff like sms, ipod, safari, phone, app store etc.

    Everything was working fine until i loaded a bunch of music on last night. Should i do a full restore?
     
  11. schubes macrumors regular

    schubes

    Joined:
    Jul 14, 2008
    Location:
    British Columbia
    #11
    This worked for me! Thanks for the solution. I recommend this to anyone having this problem
     
  12. thorbenh thread starter macrumors member

    Joined:
    Mar 23, 2008
    #12
    It still doesn´t work for me. It did the last time and it the phone worked perfectly for almost a week and now it´s the same **** again. I really don´t know what to do ...
     

Share This Page