3gs - 3.1.2 No Service

Discussion in 'Jailbreaks and iOS Hacks' started by kickrz, Jun 24, 2010.

  1. kickrz macrumors member

    Joined:
    Mar 20, 2010
    #1
    I am trying to fix my husbands phone and have no idea what to do next. I can connect to wifi but it says no service, when I click on my carrier it says restricted.

    Can someone please walk me through this so I can get his phone working please :)

    3GS
    Version - 3.1.2
    Firmware 05.12.01
    JB using sn0wbreeze and tried the unlock with ultrasn0w today.
     
  2. Cinemagic macrumors 6502

    Joined:
    Sep 26, 2007
    #2
    Did you already try to update to 4.0? If so, then the baseband has been changed and cannot by undone. If this is the case, you will need to update to 4.0 jailbreak following the standard instructions. If not and you have the old baseband, you can get a copy of the old firmware 3.1.2 and restore using it. Note that you must use the Cydia redirect - assuming you have he SHSH hashes on file with Cydia. Once you've restored, you can start again with the jailbreak and unlock.
     
  3. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #3
    So you're trying to unlock it to use on unofficial carrier?
    Not sure whats up with snowbreeze, I advise people to stay away from them.
    Did you activate with official simcard or hactivate?
    Do you have SHSH's on file to restore to previous firmware?
     
  4. kickrz thread starter macrumors member

    Joined:
    Mar 20, 2010
    #4
    Thanks. I got it. Turns out that my carrier deactivated my SIM card :rolleyes:

    So happy it is finally back and running right.

    Thank you again to all who helped on this several month journey.
     
  5. pixelated macrumors 6502a

    pixelated

    Joined:
    Oct 21, 2008
    #5

    i think you are confusing the terms 'BaseBand'( which is the modem FW and already stated as 05.12.01) and Bootrom(which is deciding factor in whether the phone can be pwned)
    I am slightly unclear though as updating to 4.0 does not change your Bootrom, but does your Baseband... though neither of these has any impact on downgrading using SHSH.
    Conflicting BaseBand and FW can sometimes cause booting problems, but can most often be solved with irecovery or some-such.
     

Share This Page